summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2015-08-27 20:45:10 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:18:34 +0200
commit104f6413d2b8affc9133a3623bd677d99df9c31e (patch)
tree49e94f1e863d31657378a36c431a7b3706b6e34a /meta-python/recipes-extended
parentfaf070c45a67f0ad49f52bc4cb79a77f64842d93 (diff)
downloadmeta-openembedded-104f6413d2b8affc9133a3623bd677d99df9c31e.tar.gz
python-pyparted: update to 3.10.5
* add patch to fix float cast error when version is x.y.z form * add minimal parted version (>= 2.3) to RDEPENDS NOTE: If your tree defaults to an earlier parted version (e.g. 1.8.6), you will need to add PREFERRED_VERSION_parted = "3.%" to local.conf or you will see a do_compile error (complaining about required libparted version). Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch26
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.5.bb27
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb23
3 files changed, 53 insertions, 23 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch b/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
new file mode 100644
index 000000000..db3ab9fc3
--- /dev/null
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
@@ -0,0 +1,26 @@
1check_mod_version breaks if module version is of x.y.z form
2use a regex to help cast x.y.z version to a float
3
4Upstream-Status: Pending
5
6Index: git/setup.py
7===================================================================
8--- git.orig/setup.py
9+++ git/setup.py
10@@ -25,6 +25,7 @@ import glob
11 import os
12 import platform
13 import sys
14+import re
15 from distutils.ccompiler import new_compiler
16 from distutils.errors import CompileError
17 from distutils.errors import LinkError
18@@ -51,6 +52,8 @@ def pkgconfig(*packages, **kwargs):
19
20 def check_mod_version(module, version):
21 modversion = subprocess.check_output(["pkg-config", "--modversion", module])
22+ match = re.search('([0-9]+\.[0-9]+)', modversion)
23+ modversion = match.group(0)
24 if not float(modversion) >= float(version):
25 sys.stderr.write("*** Minimum required %s version: %s, found: %s\n" % (module, version, modversion,))
26 sys.exit(1)
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.5.bb b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.5.bb
new file mode 100644
index 000000000..d5b8f9ab1
--- /dev/null
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.5.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
2an interface to libparted, the GNU parted library for disk partitioning and \
3filesystem manipulation."
4SUMMARY = "Python bindings for libparted"
5HOMEPAGE = "https://github.com/rhinstaller/pyparted"
6LICENSE = "GPL-2.0+"
7LIC_FILES_CHKSUM = "\
8 file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
9 file://src/_pedmodule.c;startline=10;endline=22;md5=ebcb25dde1ac9c46e986dec79b404e7e \
10"
11DEPENDS += "parted python-re"
12
13PV = "3.10.5+git${SRCPV}"
14
15# upstream only publishes releases in github archives which are discouraged
16SRCREV = "75bba5a5c8b65b21979d69421f661f7708304191"
17SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https \
18 file://0001-fix-version-float-check.patch \
19"
20S = "${WORKDIR}/git"
21
22inherit distutils
23
24RDEPENDS_${PN} += "python-stringold python-codecs python-math parted (>= 2.3)"
25RDEPENDS_${PN}_class-native = ""
26
27BBCLASSEXTEND += "native"
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb
deleted file mode 100644
index bfb4f6f87..000000000
--- a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
2an interface to libparted, the GNU parted library for disk partitioning and \
3filesystem manipulation."
4SUMMARY = "Python bindings for libparted"
5HOMEPAGE = "https://fedorahosted.org/pyparted/"
6LICENSE = "GPL-2.0+"
7LIC_FILES_CHKSUM = "\
8 file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
9 file://src/_pedmodule.c;startline=10;endline=22;md5=70c62bd73782a03f56a0571a9f08ea46 \
10"
11DEPENDS += "parted"
12
13SRC_URI = "https://fedorahosted.org/releases/p/y/pyparted/pyparted-${PV}.tar.gz"
14SRC_URI[md5sum] = "f16c7ef7f5fa4a43fcb2a4654b487e39"
15SRC_URI[sha256sum] = "a56712e3d058ce3d859c158236dbbf45224018919efd3d880ea80f9e0d0bebbb"
16S = "${WORKDIR}/pyparted-${PV}"
17
18inherit distutils
19
20RDEPENDS_${PN} += "python-stringold python-codecs python-math"
21RDEPENDS_${PN}_class-native = ""
22
23BBCLASSEXTEND += "native"