diff options
author | Kai Kang <kai.kang@windriver.com> | 2022-04-19 09:45:20 +0800 |
---|---|---|
committer | Trevor Gamblin <tvgamblin@gmail.com> | 2022-04-22 16:26:22 +0000 |
commit | 674306a4296dcbf869ae13302b230a502537d04b (patch) | |
tree | a4ff6ec2e4ac6b5347e6403ff68f70e3fbb2230b /meta-python/recipes-extended | |
parent | b3be90be2f6ad6a794df9cf756542434dde0888b (diff) | |
download | meta-openembedded-674306a4296dcbf869ae13302b230a502537d04b.tar.gz |
python3-blivetgui: use symbolic list-add and edit- icons
Backport patch from upstream for python3-blivetgui to use symbolic
list-add and edit- icons that Adwaita dropped old ones.
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <tvgamblin@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
2 files changed, 58 insertions, 1 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch new file mode 100644 index 000000000..3a95859ad --- /dev/null +++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch | |||
@@ -0,0 +1,56 @@ | |||
1 | Upstream-Status: Backport [https://github.com/storaged-project/blivet-gui/commit/eb8ec968] | ||
2 | |||
3 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
4 | |||
5 | From eb8ec968d1ee8b4b710568b1eb8536296f90751e Mon Sep 17 00:00:00 2001 | ||
6 | From: Adam Williamson <awilliam@redhat.com> | ||
7 | Date: Thu, 17 Feb 2022 11:16:22 -0800 | ||
8 | Subject: [PATCH] Use symbolic list-add and edit- icons (Adwaita dropped old | ||
9 | ones) | ||
10 | |||
11 | adwaita-icon-theme 42 no longer includes the non-symbolic icons | ||
12 | for these names. The choices are to switch to symbolic ones or | ||
13 | carry the non-symbolic ones downstream. | ||
14 | |||
15 | Signed-off-by: Adam Williamson <awilliam@redhat.com> | ||
16 | --- | ||
17 | blivetgui/list_actions.py | 8 ++++---- | ||
18 | blivetgui/processing_window.py | 6 +++--- | ||
19 | 2 files changed, 7 insertions(+), 7 deletions(-) | ||
20 | |||
21 | diff --git a/blivetgui/list_actions.py b/blivetgui/list_actions.py | ||
22 | index b7c1f9c..5388feb 100644 | ||
23 | --- a/blivetgui/list_actions.py | ||
24 | +++ b/blivetgui/list_actions.py | ||
25 | @@ -48,10 +48,10 @@ def __init__(self, blivet_gui): | ||
26 | self.blivet_gui = blivet_gui | ||
27 | |||
28 | icon_theme = Gtk.IconTheme.get_default() # pylint: disable=no-value-for-parameter | ||
29 | - icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add", 16, 0) | ||
30 | - icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete", 16, 0) | ||
31 | - icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all", 16, 0) | ||
32 | - icon_misc = Gtk.IconTheme.load_icon(icon_theme, "edit-paste", 16, 0) | ||
33 | + icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add-symbolic", 16, 0) | ||
34 | + icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete-symbolic", 16, 0) | ||
35 | + icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all-symbolic", 16, 0) | ||
36 | + icon_misc = Gtk.IconTheme.load_icon(icon_theme, "edit-paste-symbolic", 16, 0) | ||
37 | |||
38 | self.action_icons = {"add": icon_add, "delete": icon_delete, "edit": icon_edit, | ||
39 | "misc": icon_misc} | ||
40 | diff --git a/blivetgui/processing_window.py b/blivetgui/processing_window.py | ||
41 | index c400f90..a020ae8 100644 | ||
42 | --- a/blivetgui/processing_window.py | ||
43 | +++ b/blivetgui/processing_window.py | ||
44 | @@ -93,9 +93,9 @@ def add_action_view(self): | ||
45 | """ | ||
46 | |||
47 | icon_theme = Gtk.IconTheme.get_default() # pylint: disable=no-value-for-parameter | ||
48 | - icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add", 16, 0) | ||
49 | - icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete", 16, 0) | ||
50 | - icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all", 16, 0) | ||
51 | + icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add-symbolic", 16, 0) | ||
52 | + icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete-symbolic", 16, 0) | ||
53 | + icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all-symbolic", 16, 0) | ||
54 | |||
55 | actions_list = Gtk.ListStore(GdkPixbuf.Pixbuf, str, GdkPixbuf.Pixbuf) | ||
56 | |||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb index c26ae1fe9..29e7a267d 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb +++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb | |||
@@ -11,7 +11,8 @@ B = "${S}" | |||
11 | SRCREV = "42512ee48494cee71febf04078d9774f0146a085" | 11 | SRCREV = "42512ee48494cee71febf04078d9774f0146a085" |
12 | SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protocol=https \ | 12 | SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protocol=https \ |
13 | file://0001-Use-setuptools-instead-of-distutils-in-setup.py.patch \ | 13 | file://0001-Use-setuptools-instead-of-distutils-in-setup.py.patch \ |
14 | " | 14 | file://0002-Use-symbolic-list-add-and-edit-icons.patch \ |
15 | " | ||
15 | 16 | ||
16 | inherit features_check | 17 | inherit features_check |
17 | REQUIRED_DISTRO_FEATURES = "x11 systemd" | 18 | REQUIRED_DISTRO_FEATURES = "x11 systemd" |