diff options
author | Derek Straka <derek@asterius.io> | 2017-12-03 15:04:17 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-06-22 10:52:33 -0700 |
commit | 7516e8453a6eaac6cec7ac6251418fb047bccc8f (patch) | |
tree | 77858f849201ed20fe0fb3d1590ade8e526193bf /meta-python/recipes-extended | |
parent | aef6a9c67591d2f8ca6b5af7250b72d22412aef7 (diff) | |
download | meta-openembedded-7516e8453a6eaac6cec7ac6251418fb047bccc8f.tar.gz |
python-pywbem: update to version 0.11.0 and add a python3 recipe
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r-- | meta-python/recipes-extended/pywbem/python-pywbem.inc (renamed from meta-python/recipes-extended/pywbem/pywbem_0.8.0.bb) | 36 | ||||
-rw-r--r-- | meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb | 13 | ||||
-rw-r--r-- | meta-python/recipes-extended/pywbem/python3-pywbem_0.11.0.bb | 2 |
3 files changed, 39 insertions, 12 deletions
diff --git a/meta-python/recipes-extended/pywbem/pywbem_0.8.0.bb b/meta-python/recipes-extended/pywbem/python-pywbem.inc index 7f1986e51..5151c33ea 100644 --- a/meta-python/recipes-extended/pywbem/pywbem_0.8.0.bb +++ b/meta-python/recipes-extended/pywbem/python-pywbem.inc | |||
@@ -12,25 +12,37 @@ at http://www.dmtf.org/standards/wbem. \ | |||
12 | \ | 12 | \ |
13 | It also provides a Python provider interface, and is the fastest and easiest \ | 13 | It also provides a Python provider interface, and is the fastest and easiest \ |
14 | way to write providers on the planet." | 14 | way to write providers on the planet." |
15 | HOMEPAGE = "http://pywbem.sf.net/" | 15 | HOMEPAGE = "http://pywbem.github.io" |
16 | LICENSE = "LGPLv2" | 16 | LICENSE = "LGPLv2.1" |
17 | LIC_FILES_CHKSUM = "file://pywbem/LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" | 17 | LIC_FILES_CHKSUM = "file://pywbem/LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" |
18 | SECTION = "Development/Libraries" | 18 | SRC_URI[md5sum] = "1465dfa92e4cbe558c773838b9b00711" |
19 | DEPENDS = "python-m2crypto-native python-typing-native" | 19 | SRC_URI[sha256sum] = "2a05f2c1a6ab4b08560a6da55fdaabd0f52f4d1e6df6e288b9ed927bf5c289ed" |
20 | SRC_URI = "http://jaist.dl.sourceforge.net/project/${BPN}/${BPN}/${BP}/${BP}-dev.r704.zip" | ||
21 | SRC_URI[md5sum] = "84072451dcdd1aa9ee82363848faf7ad" | ||
22 | SRC_URI[sha256sum] = "898035866d3cc741bbcd62c4ac26e633ad07b7c11d89db2472b9f923f3fd3ed8" | ||
23 | 20 | ||
24 | S = "${WORKDIR}/${BP}-dev" | 21 | inherit pypi |
25 | 22 | ||
26 | inherit setuptools python-dir | 23 | DEPENDS += " \ |
24 | ${PYTHON_PN}-ply-native \ | ||
25 | ${PYTHON_PN}-pyyaml-native \ | ||
26 | ${PYTHON_PN}-six-native \ | ||
27 | " | ||
27 | 28 | ||
28 | do_install_append() { | 29 | do_install_append() { |
29 | mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli | 30 | mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli |
30 | mv ${D}${bindir}/mof_compiler.py ${D}${bindir}/mofcomp | ||
31 | 31 | ||
32 | rm ${D}${libdir}/python2.7/site-packages/${BPN}/wbemcli.py* | 32 | rm -f ${D}${bindir}/*.bat |
33 | rm ${D}${libdir}/python2.7/site-packages/${BPN}/mof_compiler.py* | ||
34 | } | 33 | } |
35 | 34 | ||
35 | RDEPENDS_${PN}_class-target += "\ | ||
36 | ${PYTHON_PN}-datetime \ | ||
37 | ${PYTHON_PN}-io \ | ||
38 | ${PYTHON_PN}-netclient \ | ||
39 | ${PYTHON_PN}-ply \ | ||
40 | ${PYTHON_PN}-pyyaml \ | ||
41 | ${PYTHON_PN}-six \ | ||
42 | ${PYTHON_PN}-stringold \ | ||
43 | ${PYTHON_PN}-threading \ | ||
44 | ${PYTHON_PN}-unixadmin \ | ||
45 | ${PYTHON_PN}-xml \ | ||
46 | " | ||
47 | |||
36 | BBCLASSEXTEND = "native" | 48 | BBCLASSEXTEND = "native" |
diff --git a/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb b/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb new file mode 100644 index 000000000..741074907 --- /dev/null +++ b/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | require python-pywbem.inc | ||
2 | inherit setuptools | ||
3 | |||
4 | DEPENDS += " \ | ||
5 | ${PYTHON_PN}-m2crypto-native \ | ||
6 | ${PYTHON_PN}-typing-native \ | ||
7 | " | ||
8 | |||
9 | RDEPENDS_${PN}_class-target += "\ | ||
10 | ${PYTHON_PN}-argparse \ | ||
11 | ${PYTHON_PN}-m2crypto \ | ||
12 | ${PYTHON_PN}-subprocess \ | ||
13 | " | ||
diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_0.11.0.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_0.11.0.bb new file mode 100644 index 000000000..6a35a8744 --- /dev/null +++ b/meta-python/recipes-extended/pywbem/python3-pywbem_0.11.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require python-pywbem.inc | ||
2 | inherit setuptools3 | ||