summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-22 02:44:54 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-25 10:32:30 -0700
commitd275208fcaa01ac151b8c324b6047ad9d9d90706 (patch)
tree122b8e86b1140c3f8b4a125625af427750c9acb2 /meta-python/recipes-extended
parent88348389707b488d5fa8e81f91267874b2fb82c4 (diff)
downloadmeta-openembedded-d275208fcaa01ac151b8c324b6047ad9d9d90706.tar.gz
python3-pywbem: Upgrade 0.17.4 -> 1.0.2
Upgrade to release 1.0.2: - Fixed erronously raised HeaderParseError when WBEM server returns Content-type: text/xml. This content-type is valid according to DSP0200. Added testcases. - Fixed handling of ReturnQueryResultClass=True in WBEMConnection.OpenQueryInstances(). - Mock: In the mock support, fixed multiple errors in the mocked OpenQueryInstances(), and added testcases for it. - Mock: Added support for more ways the output parameters can be returned in method providers: The container for the output parameters can now also be a Mapping (including pywbem’s internal NocaseDict or nocasedict.NocaseDict), in addition to just the built-in dict. The values in such a Mapping container can now also be CIMParameter objects, in addition to just the CIM data values. This provides consistency with the way the input parameters of the method provider are represented. Removed the wbemcli command that was deprecated in pywbem 0.15.0. The recommended replacement is the pywbemcli command from the 'pywbemtools' package. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/pywbem/python3-pywbem_1.0.2.bb (renamed from meta-python/recipes-extended/pywbem/python3-pywbem_0.17.4.bb)14
1 files changed, 3 insertions, 11 deletions
diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_0.17.4.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_1.0.2.bb
index a804b0cc0..da731989d 100644
--- a/meta-python/recipes-extended/pywbem/python3-pywbem_0.17.4.bb
+++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.0.2.bb
@@ -16,8 +16,8 @@ HOMEPAGE = "http://pywbem.github.io"
16LICENSE = "LGPLv2.1" 16LICENSE = "LGPLv2.1"
17LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" 17LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
18 18
19SRC_URI[md5sum] = "b65c03026bf2174e58e3e47a5e7e4825" 19SRC_URI[md5sum] = "0f171e365e294554f8e7624ccf511067"
20SRC_URI[sha256sum] = "5b54b65a5434bb16432415743c0d154feee0c6d7a8a2fee208719c67d6d24c97" 20SRC_URI[sha256sum] = "66d8ec82d30f2b95d8b4bd51659429066c2879d3f46292561f5fdbc7fed10f3d"
21 21
22inherit pypi setuptools3 update-alternatives 22inherit pypi setuptools3 update-alternatives
23 23
@@ -27,12 +27,6 @@ DEPENDS += " \
27 ${PYTHON_PN}-six-native \ 27 ${PYTHON_PN}-six-native \
28" 28"
29 29
30do_install_append() {
31 mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli
32
33 rm -f ${D}${bindir}/*.bat
34}
35
36RDEPENDS_${PN}_class-target += "\ 30RDEPENDS_${PN}_class-target += "\
37 ${PYTHON_PN}-datetime \ 31 ${PYTHON_PN}-datetime \
38 ${PYTHON_PN}-io \ 32 ${PYTHON_PN}-io \
@@ -46,10 +40,8 @@ RDEPENDS_${PN}_class-target += "\
46 ${PYTHON_PN}-xml \ 40 ${PYTHON_PN}-xml \
47" 41"
48 42
49ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli" 43ALTERNATIVE_${PN} = "mof_compiler"
50ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler" 44ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
51ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
52ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
53 45
54ALTERNATIVE_PRIORITY = "60" 46ALTERNATIVE_PRIORITY = "60"
55 47