diff options
author | Mark Hatle <mark.hatle@windriver.com> | 2017-09-05 14:00:04 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-09-13 11:08:46 +0200 |
commit | 21fb078ce1651de0fb2f7876e6d8e5e3de728a95 (patch) | |
tree | 6e9c8e5c9459b2214ee8b1fc74db27fad4db18d3 /meta-python/recipes-extended/pywbem | |
parent | 836766e5cf5b0af2a63415d18449a0966816aedb (diff) | |
download | meta-openembedded-21fb078ce1651de0fb2f7876e6d8e5e3de728a95.tar.gz |
pywbem: Requires python-m2crypto-native (and others) from meta-python
Move pywbem to the meta-python layer to avoid missing requirements.
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended/pywbem')
-rw-r--r-- | meta-python/recipes-extended/pywbem/pywbem_0.8.0.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/pywbem/pywbem_0.8.0.bb b/meta-python/recipes-extended/pywbem/pywbem_0.8.0.bb new file mode 100644 index 000000000..7f1986e51 --- /dev/null +++ b/meta-python/recipes-extended/pywbem/pywbem_0.8.0.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | SUMMARY = "Python WBEM Client and Provider Interface" | ||
2 | DESCRIPTION = "\ | ||
3 | A Python library for making CIM (Common Information Model) operations over \ | ||
4 | HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \ | ||
5 | WBEM client should be easy to use and not necessarily require a large amount \ | ||
6 | of programming knowledge. It is suitable for a large range of tasks from \ | ||
7 | simply poking around to writing web and GUI applications. \ | ||
8 | \ | ||
9 | WBEM, or Web Based Enterprise Management is a manageability protocol, like \ | ||
10 | SNMP, standardised by the Distributed Management Task Force (DMTF) available \ | ||
11 | at http://www.dmtf.org/standards/wbem. \ | ||
12 | \ | ||
13 | It also provides a Python provider interface, and is the fastest and easiest \ | ||
14 | way to write providers on the planet." | ||
15 | HOMEPAGE = "http://pywbem.sf.net/" | ||
16 | LICENSE = "LGPLv2" | ||
17 | LIC_FILES_CHKSUM = "file://pywbem/LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" | ||
18 | SECTION = "Development/Libraries" | ||
19 | DEPENDS = "python-m2crypto-native python-typing-native" | ||
20 | SRC_URI = "http://jaist.dl.sourceforge.net/project/${BPN}/${BPN}/${BP}/${BP}-dev.r704.zip" | ||
21 | SRC_URI[md5sum] = "84072451dcdd1aa9ee82363848faf7ad" | ||
22 | SRC_URI[sha256sum] = "898035866d3cc741bbcd62c4ac26e633ad07b7c11d89db2472b9f923f3fd3ed8" | ||
23 | |||
24 | S = "${WORKDIR}/${BP}-dev" | ||
25 | |||
26 | inherit setuptools python-dir | ||
27 | |||
28 | do_install_append() { | ||
29 | mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli | ||
30 | mv ${D}${bindir}/mof_compiler.py ${D}${bindir}/mofcomp | ||
31 | |||
32 | rm ${D}${libdir}/python2.7/site-packages/${BPN}/wbemcli.py* | ||
33 | rm ${D}${libdir}/python2.7/site-packages/${BPN}/mof_compiler.py* | ||
34 | } | ||
35 | |||
36 | BBCLASSEXTEND = "native" | ||