diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2018-08-14 00:22:18 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-15 08:20:06 -0700 |
commit | 8e36191fbe07c1a84e4a58423178b01f09dcd5b7 (patch) | |
tree | f8eab9ed2ae88fd51d38f28dde1bd226c47e4e1c /meta-python/recipes-extended/python-blivet | |
parent | 83c49777fc92f0673a6ddf735e53d8783b5a6ff5 (diff) | |
download | meta-openembedded-8e36191fbe07c1a84e4a58423178b01f09dcd5b7.tar.gz |
python3-blivet: remove dmraid from dependency check
OE does not have dmraid recipe, so remove it from dependency check.
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended/python-blivet')
-rw-r--r-- | meta-python/recipes-extended/python-blivet/python3-blivet/0012-remove-dmraid-dependency-check.patch | 31 | ||||
-rw-r--r-- | meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb | 1 |
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0012-remove-dmraid-dependency-check.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0012-remove-dmraid-dependency-check.patch new file mode 100644 index 000000000..886e3ff93 --- /dev/null +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0012-remove-dmraid-dependency-check.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 4476e846a1e64dde17df2e2370c803ce695514f9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Mon, 6 Aug 2018 17:18:27 +0800 | ||
4 | Subject: [PATCH] remove dmraid dependency check | ||
5 | |||
6 | OE does not support dmraid, remove it from dependency check | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | |||
10 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
11 | --- | ||
12 | blivet/tasks/availability.py | 3 +-- | ||
13 | 1 file changed, 1 insertion(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/blivet/tasks/availability.py b/blivet/tasks/availability.py | ||
16 | index 9a87cfd..843cf6a 100644 | ||
17 | --- a/blivet/tasks/availability.py | ||
18 | +++ b/blivet/tasks/availability.py | ||
19 | @@ -316,8 +316,7 @@ BLOCKDEV_DM_ALL_MODES = (blockdev.DMTechMode.CREATE_ACTIVATE | | ||
20 | blockdev.DMTechMode.QUERY) | ||
21 | BLOCKDEV_DM = BlockDevTechInfo(plugin_name="dm", | ||
22 | check_fn=blockdev.dm_is_tech_avail, | ||
23 | - technologies={blockdev.DMTech.MAP: BLOCKDEV_DM_ALL_MODES, | ||
24 | - blockdev.DMTech.RAID: BLOCKDEV_DM_ALL_MODES}) | ||
25 | + technologies={blockdev.DMTech.MAP: BLOCKDEV_DM_ALL_MODES}) | ||
26 | BLOCKDEV_DM_TECH = BlockDevMethod(BLOCKDEV_DM) | ||
27 | |||
28 | # libblockdev loop plugin required technologies and modes | ||
29 | -- | ||
30 | 2.7.4 | ||
31 | |||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb index 218c158c6..5fcbd88eb 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb +++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb | |||
@@ -21,6 +21,7 @@ SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \ | |||
21 | file://0009-invoking-fsck-with-infinite-timeout.patch \ | 21 | file://0009-invoking-fsck-with-infinite-timeout.patch \ |
22 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ | 22 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ |
23 | file://0011-invoking-dd-with-infinite-timeout.patch \ | 23 | file://0011-invoking-dd-with-infinite-timeout.patch \ |
24 | file://0012-remove-dmraid-dependency-check.patch \ | ||
24 | " | 25 | " |
25 | 26 | ||
26 | UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$" | 27 | UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$" |