summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-blivet
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2023-11-02 14:29:24 +0800
committerKhem Raj <raj.khem@gmail.com>2023-11-02 10:39:36 -0700
commit3e26d8deeba0318fe574f53ac798b55062999dfb (patch)
tree51f65cb3968adfb132fb85368b3019d90a9a7c8e /meta-python/recipes-extended/python-blivet
parentd6b19d69b285a26b7d7a318ded42b04ccfb0a4a6 (diff)
downloadmeta-openembedded-3e26d8deeba0318fe574f53ac798b55062999dfb.tar.gz
python3-blivetgui: 2.3.0 -> 2.4.2
Update python3-blivetgui from 2.3.0 to 2.4.2 * drop patches that there are not needed any more * not set var `B` that out of source tree build is supported * inherit setuptools3 rather than setuptools3_legacy Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended/python-blivet')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch30
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch56
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb (renamed from meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb)18
3 files changed, 5 insertions, 99 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch
deleted file mode 100644
index c88912bfa..000000000
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Use-setuptools-instead-of-distutils-in-setup.py.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 54014061be2fed20d6c35aba9719ea70a9fea9ea Mon Sep 17 00:00:00 2001
2From: Vojtech Trefny <vtrefny@redhat.com>
3Date: Wed, 1 Sep 2021 08:59:19 +0200
4Subject: [PATCH] Use setuptools instead of distutils in setup.py
5
6The distutils module is deprecated and will be removed in Python
73.12.
8
9Upstream-Status: Backport [https://github.com/kraj/blivet-gui/commit/54014061be2fed20d6c35aba9719ea70a9fea9ea]
10---
11 setup.py | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/setup.py b/setup.py
15index aa8ef57..77849a1 100644
16--- a/setup.py
17+++ b/setup.py
18@@ -1,7 +1,7 @@
19 from __future__ import print_function
20
21-from distutils.core import setup
22-from distutils.command.sdist import sdist
23+from setuptools import setup
24+from setuptools.command.sdist import sdist
25 import glob
26 import sys
27
28--
292.35.1
30
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch
deleted file mode 100644
index 3a95859ad..000000000
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1Upstream-Status: Backport [https://github.com/storaged-project/blivet-gui/commit/eb8ec968]
2
3Signed-off-by: Kai Kang <kai.kang@windriver.com>
4
5From eb8ec968d1ee8b4b710568b1eb8536296f90751e Mon Sep 17 00:00:00 2001
6From: Adam Williamson <awilliam@redhat.com>
7Date: Thu, 17 Feb 2022 11:16:22 -0800
8Subject: [PATCH] Use symbolic list-add and edit- icons (Adwaita dropped old
9 ones)
10
11adwaita-icon-theme 42 no longer includes the non-symbolic icons
12for these names. The choices are to switch to symbolic ones or
13carry the non-symbolic ones downstream.
14
15Signed-off-by: Adam Williamson <awilliam@redhat.com>
16---
17 blivetgui/list_actions.py | 8 ++++----
18 blivetgui/processing_window.py | 6 +++---
19 2 files changed, 7 insertions(+), 7 deletions(-)
20
21diff --git a/blivetgui/list_actions.py b/blivetgui/list_actions.py
22index b7c1f9c..5388feb 100644
23--- a/blivetgui/list_actions.py
24+++ b/blivetgui/list_actions.py
25@@ -48,10 +48,10 @@ def __init__(self, blivet_gui):
26 self.blivet_gui = blivet_gui
27
28 icon_theme = Gtk.IconTheme.get_default() # pylint: disable=no-value-for-parameter
29- icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add", 16, 0)
30- icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete", 16, 0)
31- icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all", 16, 0)
32- icon_misc = Gtk.IconTheme.load_icon(icon_theme, "edit-paste", 16, 0)
33+ icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add-symbolic", 16, 0)
34+ icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete-symbolic", 16, 0)
35+ icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all-symbolic", 16, 0)
36+ icon_misc = Gtk.IconTheme.load_icon(icon_theme, "edit-paste-symbolic", 16, 0)
37
38 self.action_icons = {"add": icon_add, "delete": icon_delete, "edit": icon_edit,
39 "misc": icon_misc}
40diff --git a/blivetgui/processing_window.py b/blivetgui/processing_window.py
41index c400f90..a020ae8 100644
42--- a/blivetgui/processing_window.py
43+++ b/blivetgui/processing_window.py
44@@ -93,9 +93,9 @@ def add_action_view(self):
45 """
46
47 icon_theme = Gtk.IconTheme.get_default() # pylint: disable=no-value-for-parameter
48- icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add", 16, 0)
49- icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete", 16, 0)
50- icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all", 16, 0)
51+ icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add-symbolic", 16, 0)
52+ icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete-symbolic", 16, 0)
53+ icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all-symbolic", 16, 0)
54
55 actions_list = Gtk.ListStore(GdkPixbuf.Pixbuf, str, GdkPixbuf.Pixbuf)
56
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
index 42bcf4651..b6e04e081 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
@@ -5,20 +5,14 @@ SECTION = "devel/python"
5 5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7 7
8S = "${WORKDIR}/git" 8SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=main;protocol=https"
9B = "${S}" 9SRCREV = "9b6a83a7aef546ddacafcc656984c9bbed67a8ec"
10 10
11SRCREV = "42512ee48494cee71febf04078d9774f0146a085" 11S = "${WORKDIR}/git"
12SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=main;protocol=https \
13 file://0001-Use-setuptools-instead-of-distutils-in-setup.py.patch \
14 file://0002-Use-symbolic-list-add-and-edit-icons.patch \
15 "
16 12
17inherit features_check 13inherit features_check setuptools3
18REQUIRED_DISTRO_FEATURES = "x11 systemd gobject-introspection-data" 14REQUIRED_DISTRO_FEATURES = "x11 systemd gobject-introspection-data"
19 15
20inherit setuptools3_legacy python3native
21
22PIP_INSTALL_PACKAGE = "blivet_gui" 16PIP_INSTALL_PACKAGE = "blivet_gui"
23 17
24RDEPENDS:${PN} = "python3-pygobject python3 \ 18RDEPENDS:${PN} = "python3-pygobject python3 \
@@ -26,6 +20,4 @@ RDEPENDS:${PN} = "python3-pygobject python3 \
26 python3-pid libreport \ 20 python3-pid libreport \
27" 21"
28 22
29FILES:${PN} += " \ 23FILES:${PN} += "${datadir}/*"
30 ${datadir}/* \
31 "