diff options
author | Derek Straka <derek@asterius.io> | 2017-07-05 10:00:22 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-14 23:44:31 +0200 |
commit | c974fbf9ebf185552ab65301e07af44f36517abf (patch) | |
tree | e5df11fa16ca50f17ad4ea1d81c64ff588609690 /meta-python/recipes-devtools | |
parent | 941ad264a6f9e6b21860c3834ce235b791912972 (diff) | |
download | meta-openembedded-c974fbf9ebf185552ab65301e07af44f36517abf.tar.gz |
python-pytest: remove fetch during do_compile phase
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pytest.inc | 4 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch | 29 |
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc index 22795964d..b5c1fa82a 100644 --- a/meta-python/recipes-devtools/python/python-pytest.inc +++ b/meta-python/recipes-devtools/python/python-pytest.inc | |||
@@ -5,6 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c39b24965f4aef64222cb35de9d47cc4" | |||
5 | SRC_URI[md5sum] = "35356e6e31cbd8318e8b2a8340a90b72" | 5 | SRC_URI[md5sum] = "35356e6e31cbd8318e8b2a8340a90b72" |
6 | SRC_URI[sha256sum] = "095e1832f7e424563c95daf4d8d3c865052b80e139cdd2f9610a986ee8526206" | 6 | SRC_URI[sha256sum] = "095e1832f7e424563c95daf4d8d3c865052b80e139cdd2f9610a986ee8526206" |
7 | 7 | ||
8 | SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch" | ||
9 | |||
8 | RDEPENDS_${PN}_class-target += " \ | 10 | RDEPENDS_${PN}_class-target += " \ |
9 | ${PYTHON_PN}-argparse \ | 11 | ${PYTHON_PN}-argparse \ |
10 | ${PYTHON_PN}-debugger \ | 12 | ${PYTHON_PN}-debugger \ |
@@ -13,4 +15,6 @@ RDEPENDS_${PN}_class-target += " \ | |||
13 | ${PYTHON_PN}-setuptools \ | 15 | ${PYTHON_PN}-setuptools \ |
14 | " | 16 | " |
15 | 17 | ||
18 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:" | ||
19 | |||
16 | BBCLASSEXTEND = "native nativesdk" | 20 | BBCLASSEXTEND = "native nativesdk" |
diff --git a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch new file mode 100644 index 000000000..e283b17c4 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From e2d81009c790b4ebeced8408b6bae78060cabcaf Mon Sep 17 00:00:00 2001 | ||
2 | From: Derek Straka <derek@asterius.io> | ||
3 | Date: Wed, 5 Jul 2017 09:35:51 -0400 | ||
4 | Subject: [PATCH 1/1] setup.py: remove the setup_requires for setuptools-scm | ||
5 | |||
6 | The setup_requires argument forces the download of the egg file for setuptools-scm | ||
7 | during the do_compile phase. This download is incompatible with the typical fetch | ||
8 | and mirror structure. The only usage of scm is the generation of the _version.py | ||
9 | file and in the release tarball it is already correctly created | ||
10 | |||
11 | Signed-off-by: Derek Straka <derek@asterius.io> | ||
12 | --- | ||
13 | setup.py | 1 - | ||
14 | 1 file changed, 1 deletion(-) | ||
15 | |||
16 | diff --git a/setup.py b/setup.py | ||
17 | index 751868c..ef6ebf1 100644 | ||
18 | --- a/setup.py | ||
19 | +++ b/setup.py | ||
20 | @@ -71,7 +71,6 @@ def main(): | ||
21 | keywords="test unittest", | ||
22 | cmdclass={'test': PyTest}, | ||
23 | # the following should be enabled for release | ||
24 | - setup_requires=['setuptools-scm'], | ||
25 | install_requires=install_requires, | ||
26 | extras_require=extras_require, | ||
27 | packages=['_pytest', '_pytest.assertion', '_pytest._code', '_pytest.vendored_packages'], | ||
28 | -- | ||
29 | 2.7.4 | ||