diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2017-05-26 03:37:31 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-06-05 11:01:47 +0200 |
commit | ab2ca92e8322549aa3f13af0c903aa80bd6f10ad (patch) | |
tree | ae3995da31c010210facb675f5b09d051aaaa0ba /meta-python/recipes-devtools | |
parent | abc5a71c4d216742dc2af4b475136262ac169612 (diff) | |
download | meta-openembedded-ab2ca92e8322549aa3f13af0c903aa80bd6f10ad.tar.gz |
python3-pyudev: add a python3 recipe
- Split to a common python-pyudev.inc for python2 and python3
- The contextlib module is moved to python3-lang.
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
3 files changed, 31 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyudev.inc b/meta-python/recipes-devtools/python/python-pyudev.inc new file mode 100644 index 000000000..ab4c5fd7d --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pyudev.inc | |||
@@ -0,0 +1,19 @@ | |||
1 | SUMMARY = "A libudev binding" | ||
2 | LICENSE = "LGPLv2.1+" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" | ||
4 | |||
5 | SRC_URI[md5sum] = "cf4d9db7d772622144ca1be6b5d9353b" | ||
6 | SRC_URI[sha256sum] = "094b7a100150114748aaa3b70663485dd360457a709bfaaafe5a977371033f2b" | ||
7 | |||
8 | do_configure_prepend() { | ||
9 | sed -i "/import pyudev/d" ${S}/setup.py | ||
10 | sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py | ||
11 | } | ||
12 | |||
13 | RDEPENDS_${PN} = "\ | ||
14 | ${PYTHON_PN}-ctypes \ | ||
15 | ${PYTHON_PN}-misc \ | ||
16 | ${PYTHON_PN}-six \ | ||
17 | ${PYTHON_PN}-subprocess \ | ||
18 | ${PYTHON_PN}-threading \ | ||
19 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb b/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb index b0a1acb48..32573b7a0 100644 --- a/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb +++ b/meta-python/recipes-devtools/python/python-pyudev_0.21.0.bb | |||
@@ -1,22 +1,8 @@ | |||
1 | SUMMARY = "A libudev binding" | 1 | require python-pyudev.inc |
2 | LICENSE = "LGPLv2.1+" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" | ||
4 | |||
5 | SRC_URI[md5sum] = "cf4d9db7d772622144ca1be6b5d9353b" | ||
6 | SRC_URI[sha256sum] = "094b7a100150114748aaa3b70663485dd360457a709bfaaafe5a977371033f2b" | ||
7 | |||
8 | inherit pypi setuptools | ||
9 | |||
10 | do_configure_prepend() { | ||
11 | sed -i "/import pyudev/d" ${S}/setup.py | ||
12 | sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py | ||
13 | } | ||
14 | 2 | ||
15 | RDEPENDS_${PN} = "\ | 3 | RDEPENDS_${PN} = "\ |
16 | ${PYTHON_PN}-contextlib \ | 4 | ${PYTHON_PN}-contextlib \ |
17 | ${PYTHON_PN}-ctypes \ | ||
18 | ${PYTHON_PN}-misc \ | ||
19 | ${PYTHON_PN}-six \ | ||
20 | ${PYTHON_PN}-subprocess \ | ||
21 | ${PYTHON_PN}-threading \ | ||
22 | " | 5 | " |
6 | |||
7 | inherit pypi setuptools | ||
8 | |||
diff --git a/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb b/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb new file mode 100644 index 000000000..0292555c7 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | require python-pyudev.inc | ||
2 | |||
3 | RDEPENDS_${PN} = "\ | ||
4 | ${PYTHON_PN}-lang \ | ||
5 | " | ||
6 | |||
7 | inherit pypi setuptools3 | ||
8 | |||