diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2016-05-24 14:56:54 +0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-06-08 14:55:25 +0200 |
commit | f9ce43cdf6639acaa59d6144aabee798970ca3b6 (patch) | |
tree | 4cd53cb95eb5e514d834a65cdbdfa1d8739532c8 /meta-python/recipes-devtools | |
parent | e5f01cae3885030f8b3c585e62e7dd7f84a278d9 (diff) | |
download | meta-openembedded-f9ce43cdf6639acaa59d6144aabee798970ca3b6.tar.gz |
Remove unnecessary exports of HOST_SYS and BUILD_SYS in python-based recipes
They are no longer required to build python software.
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
3 files changed, 0 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb b/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb index 69f71c711..133e66da4 100644 --- a/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb +++ b/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb | |||
@@ -19,15 +19,12 @@ EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../" | |||
19 | inherit distutils | 19 | inherit distutils |
20 | 20 | ||
21 | do_compile_prepend() { | 21 | do_compile_prepend() { |
22 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
23 | ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ | 22 | ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ |
24 | true | 23 | true |
25 | } | 24 | } |
26 | 25 | ||
27 | # need to export these variables for python-config to work | 26 | # need to export these variables for python-config to work |
28 | export PYTHONPATH | 27 | export PYTHONPATH |
29 | export BUILD_SYS | ||
30 | export HOST_SYS | ||
31 | export STAGING_INCDIR | 28 | export STAGING_INCDIR |
32 | export STAGING_LIBDIR | 29 | export STAGING_LIBDIR |
33 | 30 | ||
diff --git a/meta-python/recipes-devtools/python/python-six.inc b/meta-python/recipes-devtools/python/python-six.inc index 408c60e88..625cbad17 100644 --- a/meta-python/recipes-devtools/python/python-six.inc +++ b/meta-python/recipes-devtools/python/python-six.inc | |||
@@ -6,7 +6,6 @@ SRC_URI[md5sum] = "34eed507548117b2ab523ab14b2f8b55" | |||
6 | SRC_URI[sha256sum] = "105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a" | 6 | SRC_URI[sha256sum] = "105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a" |
7 | 7 | ||
8 | do_compile_append() { | 8 | do_compile_append() { |
9 | export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} | ||
10 | ${PYTHON} setup.py -q bdist_egg --dist-dir ./ | 9 | ${PYTHON} setup.py -q bdist_egg --dist-dir ./ |
11 | } | 10 | } |
12 | do_install_append() { | 11 | do_install_append() { |
diff --git a/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb b/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb index e87e50f9b..0df18f5df 100644 --- a/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb +++ b/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb | |||
@@ -10,7 +10,6 @@ SRC_URI[sha256sum] = "acd43686e92e6c8bbeb4f2eef54408567a7adea9692fa72d591eec5357 | |||
10 | inherit pypi setuptools | 10 | inherit pypi setuptools |
11 | 11 | ||
12 | do_compile_append() { | 12 | do_compile_append() { |
13 | export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} | ||
14 | ${PYTHON} setup.py -q bdist_egg --dist-dir ./ | 13 | ${PYTHON} setup.py -q bdist_egg --dist-dir ./ |
15 | } | 14 | } |
16 | 15 | ||