summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2022-02-15 14:49:31 -0500
committerKhem Raj <raj.khem@gmail.com>2022-02-16 08:13:29 -0800
commitfe1d9094a285d25a1ec78da0c3400db24fde9158 (patch)
tree7170db432e079f59586810f97bfda922cdfd8cc4 /meta-python/recipes-devtools
parenta97e33665d3eaef70f8771918fad6f6f88ccf20f (diff)
downloadmeta-openembedded-fe1d9094a285d25a1ec78da0c3400db24fde9158.tar.gz
python3-pytest-xdist: add 2.5.0
Adding a pytest plugin that enables distributed testing and loop-on-failing modes. Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb b/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb
new file mode 100644
index 000000000..a10ac8cc4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb
@@ -0,0 +1,17 @@
1SUMMARY = "pytest xdist plugin for distributed testing and loop-on-failing modes"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-xdist"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
5
6SRC_URI[sha256sum] = "4580deca3ff04ddb2ac53eba39d76cb5dd5edeac050cb6fbc768b0dd712b4edf"
7
8inherit pypi setuptools3
9
10DEPENDS += "python3-setuptools-scm-native"
11
12# Note that the dependency on pytest-forked is scheduled to be dropped in 3.0
13RDEPENDS:${PN} += " \
14 python3-execnet \
15 python3-pytest \
16 python3-pytest-forked \
17"