diff options
author | Nicola Lunghi <nick83ola@gmail.com> | 2019-11-14 12:47:58 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-11-14 10:11:59 -0800 |
commit | dd81e462f703053c4da715458da2758ae7ca900b (patch) | |
tree | cbb759e256522eafcf42051083c7cc3116289567 /meta-python/recipes-devtools | |
parent | 3984ac6e4fd9091dacd420416d97a59f43039068 (diff) | |
download | meta-openembedded-dd81e462f703053c4da715458da2758ae7ca900b.tar.gz |
python-rfc3339-validator: add recipe
This is an optional dependency for python-jsonschema
Signed-off-by: Nicola Lunghi <nick83ola@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
4 files changed, 61 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-rfc3339-validator.inc b/meta-python/recipes-devtools/python/python-rfc3339-validator.inc new file mode 100644 index 000000000..3da082984 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-rfc3339-validator.inc | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "A pure python RFC3339 validator" | ||
2 | HOMEPAGE = "https://github.com/naimetti/rfc3339-validator" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6" | ||
5 | |||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3339-validator:" | ||
7 | |||
8 | SRC_URI[md5sum] = "9d8899041d83f98180bddd8b62ee7e99" | ||
9 | SRC_URI[sha256sum] = "20a600d01fbb1f793cbb6f4ec4ebb2104f4c9e80d74d5f78350b63ecc6cccd08" | ||
10 | |||
11 | PYPI_PACKAGE = "rfc3339_validator" | ||
12 | |||
13 | inherit pypi | ||
14 | |||
15 | SRC_URI_append = " \ | ||
16 | file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS_${PN} += "\ | ||
20 | ${PYTHON_PN}-core \ | ||
21 | ${PYTHON_PN}-datetime \ | ||
22 | ${PYTHON_PN}-six \ | ||
23 | " | ||
24 | |||
25 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-rfc3339-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch b/meta-python/recipes-devtools/python/python-rfc3339-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch new file mode 100644 index 000000000..ce8ca0bc8 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-rfc3339-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 2de281fdca88f223ace1eb6428a77b9903c69264 Mon Sep 17 00:00:00 2001 | ||
2 | From: Nicola Lunghi <nicola.lunghi@jci.com> | ||
3 | Date: Thu, 14 Nov 2019 11:58:28 +0000 | ||
4 | Subject: [PATCH] setup.py: move pytest-runner to test_requirements | ||
5 | |||
6 | This fixes an issue with yocto build. | ||
7 | pytest-runner is only needed when running tests. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | --- | ||
11 | setup.py | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 9a50767..e3b1c6e 100644 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -12,9 +12,9 @@ requirements = [ | ||
19 | 'six', | ||
20 | ] | ||
21 | |||
22 | -setup_requirements = ['pytest-runner', ] | ||
23 | +setup_requirements = [] | ||
24 | |||
25 | -test_requirements = ['pytest>=3', ] | ||
26 | +test_requirements = ['pytest>=3', 'pytest-runner'] | ||
27 | |||
28 | setup( | ||
29 | author="Nicolas Aimetti", | ||
30 | -- | ||
31 | 2.20.1 | ||
32 | |||
diff --git a/meta-python/recipes-devtools/python/python-rfc3339-validator_0.1.1.bb b/meta-python/recipes-devtools/python/python-rfc3339-validator_0.1.1.bb new file mode 100644 index 000000000..29b8a6e0d --- /dev/null +++ b/meta-python/recipes-devtools/python/python-rfc3339-validator_0.1.1.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-rfc3339-validator.inc \ No newline at end of file | ||
diff --git a/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb new file mode 100644 index 000000000..f4ee8feda --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-rfc3339-validator.inc \ No newline at end of file | ||