summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-01 10:58:33 -0400
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:31:30 -0800
commit63791edb3f69269fc6e0b83863e76f6a4a35965c (patch)
tree5c745f8c1f15bfa775b651acd92d95452671a198 /meta-python/recipes-devtools
parentb9e0b2abd1074f846bb3aef3670c0a461f6b1d00 (diff)
downloadmeta-openembedded-63791edb3f69269fc6e0b83863e76f6a4a35965c.tar.gz
python-incremental: add an initial recipe for version 17.5.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-incremental.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-incremental_17.5.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb2
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-incremental.inc b/meta-python/recipes-devtools/python/python-incremental.inc
new file mode 100644
index 000000000..367545868
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-incremental.inc
@@ -0,0 +1,14 @@
1DESCRIPTION = "Incremental is a small library that versions your Python projects"
2HOMEPAGE = "https://github.com/twisted/incremental"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
5
6SRC_URI[md5sum] = "602746e0d438e075a5a9e0678140bba2"
7SRC_URI[sha256sum] = "7b751696aaf36eebfab537e458929e194460051ccad279c72b755a167eebd4b3"
8
9inherit pypi
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-twisted \
13 ${PYTHON_PN}-click \
14"
diff --git a/meta-python/recipes-devtools/python/python-incremental_17.5.0.bb b/meta-python/recipes-devtools/python/python-incremental_17.5.0.bb
new file mode 100644
index 000000000..139ac0c52
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-incremental_17.5.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-incremental.inc
diff --git a/meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb b/meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb
new file mode 100644
index 000000000..0f04df4a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-incremental.inc