diff options
author | Tim Orling <ticotimo@gmail.com> | 2024-02-16 16:14:56 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-16 16:42:31 -0800 |
commit | d114bafa718c7fe774ba687b907d73683d4678e9 (patch) | |
tree | 5af11d44da6a2c26dd3620334c513c0e12539f0a /meta-python/recipes-devtools | |
parent | 21938d9432267c0abb5f9791ba41dda767135b04 (diff) | |
download | meta-openembedded-d114bafa718c7fe774ba687b907d73683d4678e9.tar.gz |
python3-fastjsonschema: switch to pytest --automake
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-fastjsonschema_2.18.0.bb | 1 |
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest b/meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest index b63c4de0d..8d2017d39 100644 --- a/meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest +++ b/meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-fastjsonschema_2.18.0.bb b/meta-python/recipes-devtools/python/python3-fastjsonschema_2.18.0.bb index e0be7b616..6b74f7260 100644 --- a/meta-python/recipes-devtools/python/python3-fastjsonschema_2.18.0.bb +++ b/meta-python/recipes-devtools/python/python3-fastjsonschema_2.18.0.bb | |||
@@ -27,6 +27,7 @@ RDEPENDS:${PN}-ptest += "\ | |||
27 | python3-pytest \ | 27 | python3-pytest \ |
28 | python3-pytest-benchmark \ | 28 | python3-pytest-benchmark \ |
29 | python3-pytest-cache \ | 29 | python3-pytest-cache \ |
30 | python3-unittest-automake-output \ | ||
30 | " | 31 | " |
31 | RDEPENDS:${PN} += "\ | 32 | RDEPENDS:${PN} += "\ |
32 | python3-core \ | 33 | python3-core \ |