diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2022-07-08 12:34:34 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-07-11 22:46:17 +0100 |
commit | 9b7f4191bfb66c756d197d2f7b5b2bf152e285de (patch) | |
tree | c1ba341b0cfdece42b1de4ed87d9c43c876509df /meta-python/recipes-devtools | |
parent | 063f7de651dbb1cd8f6c97a62d829c6fda6a48d5 (diff) | |
download | meta-openembedded-9b7f4191bfb66c756d197d2f7b5b2bf152e285de.tar.gz |
python3-networkx: Upgrade 2.7.1 -> 2.8.4
Upgrade to release 2.8.4:
- Clean up maximal_independent_set tests
- MAINT: Cleanup centrality module, remove unused variables
- importorskip scipy instead of numpy for total spanning tree
- Add initial_graph parameter to scale_free_graph and deprecate
create_using
- Add docstring example for attr transfer to linegraph.
- Update ISMAGS.analyze_symmetry docstring.
- Add default value p=2 for minkowski distance metric.
- Update inline code to inline math in docstring
- Update multigraph docstrings to reflect remove_edges_from
behavior.
- Update simple_cycles docstring w/ yields and examples
- Chromatic polynomial
- Catch ':' explicitly while working with pydot
- Revert "Add workaround for pytest failures on 3.11b2"
- Default to lightmode for documentation
- Dont compute all biconnected components in is_biconnected()
- Some more changes to make pytest-randomly happy
- Add durations flag to coverage run on CI.
- Recover order of layers in multipartite_layout when layers are
sortable
- Update doc requirements
- Touchups to MG and MDG edges docstrings.
- Add PendingDeprecation for pydot
- Add example of topo_order kwarg to dag_longest_path
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-networkx_2.8.4.bb (renamed from meta-python/recipes-devtools/python/python3-networkx_2.7.1.bb) | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-networkx_2.7.1.bb b/meta-python/recipes-devtools/python/python3-networkx_2.8.4.bb index 9e5b086a9..8181d90c0 100644 --- a/meta-python/recipes-devtools/python/python3-networkx_2.7.1.bb +++ b/meta-python/recipes-devtools/python/python3-networkx_2.8.4.bb | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "http://networkx.github.io/" | |||
3 | LICENSE = "BSD-3-Clause" | 3 | LICENSE = "BSD-3-Clause" |
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=44614b6df7cf3c19be69d0a945e29904" | 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=44614b6df7cf3c19be69d0a945e29904" |
5 | 5 | ||
6 | SRC_URI[sha256sum] = "d1194ba753e5eed07cdecd1d23c5cd7a3c772099bd8dbd2fea366788cf4de7ba" | 6 | SRC_URI[sha256sum] = "5e53f027c0d567cf1f884dbb283224df525644e43afd1145d64c9d88a3584762" |
7 | 7 | ||
8 | inherit pypi setuptools3 | 8 | inherit pypi setuptools3 |
9 | 9 | ||