diff options
author | Justin Bronder <jsbronder@cold-front.org> | 2022-03-01 11:32:58 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-03-03 08:48:06 -0800 |
commit | 4771d7f886013917d7f4cb593b4f4c32109b4452 (patch) | |
tree | 6a38b9ae42f23c21e14e14a15c7395cad1aaf895 /meta-python/recipes-devtools | |
parent | 048e1e40b216d3d00e555090e06d29170b5b14ba (diff) | |
download | meta-openembedded-4771d7f886013917d7f4cb593b4f4c32109b4452.tar.gz |
python3-crcmod: use setuptools instead of distutils
Signed-off-by: Justin Bronder <jsbronder@cold-front.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-crcmod/0001-setup.py-use-setuptools-instead-of-distutils.patch | 22 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-crcmod_1.7.bb | 2 |
2 files changed, 23 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-crcmod/0001-setup.py-use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-crcmod/0001-setup.py-use-setuptools-instead-of-distutils.patch new file mode 100644 index 000000000..9bcb87113 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-crcmod/0001-setup.py-use-setuptools-instead-of-distutils.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | From 3dc1e9584ed2ac81e7526b8dbf76b4a06ea8ac76 Mon Sep 17 00:00:00 2001 | ||
2 | From: Justin Bronder <jsbronder@cold-front.org> | ||
3 | Date: Tue, 1 Mar 2022 10:34:42 -0500 | ||
4 | Subject: [PATCH] setup.py use setuptools instead of distutils | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Justin Bronder <jsbronder@cold-front.org> | ||
8 | --- | ||
9 | setup.py | 3 +-- | ||
10 | 1 file changed, 1 insertion(+), 2 deletions(-) | ||
11 | |||
12 | diff --git a/setup.py b/setup.py | ||
13 | index e3a524b..2f2bcfc 100644 | ||
14 | --- a/setup.py | ||
15 | +++ b/setup.py | ||
16 | @@ -1,5 +1,4 @@ | ||
17 | -from distutils.core import setup | ||
18 | -from distutils.extension import Extension | ||
19 | +from setuptools import Extension, setup | ||
20 | import sys,os | ||
21 | |||
22 | if sys.version_info[0] == 2: | ||
diff --git a/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb b/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb index df8f0d83d..f8f168360 100644 --- a/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb +++ b/meta-python/recipes-devtools/python/python3-crcmod_1.7.bb | |||
@@ -4,7 +4,7 @@ LICENSE = "MIT" | |||
4 | SECTION = "devel/python" | 4 | SECTION = "devel/python" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a19291627cad2d1dfbfcf3c9fb85c2" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a19291627cad2d1dfbfcf3c9fb85c2" |
6 | 6 | ||
7 | SRC_URI[md5sum] = "2d5b92117d958dcead94f9e17f54cd32" | 7 | SRC_URI += "file://0001-setup.py-use-setuptools-instead-of-distutils.patch" |
8 | SRC_URI[sha256sum] = "dc7051a0db5f2bd48665a990d3ec1cc305a466a77358ca4492826f41f283601e" | 8 | SRC_URI[sha256sum] = "dc7051a0db5f2bd48665a990d3ec1cc305a466a77358ca4492826f41f283601e" |
9 | 9 | ||
10 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 |