summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-08-09 19:30:53 +0300
committerKhem Raj <raj.khem@gmail.com>2024-08-10 15:57:55 -0700
commit3167a3a9b5a0d5a4c6dd98b94bd0a920ab119f37 (patch)
tree016dab0acc9c760135071fdf24b0c6fa6b539fd6 /meta-python/recipes-devtools
parent834a229273d9c5e907e6049e41ea001d3074540e (diff)
downloadmeta-openembedded-3167a3a9b5a0d5a4c6dd98b94bd0a920ab119f37.tar.gz
python3-pytest-timeout: switch to PEP-517 build backend
- The project has a proper pyproject.toml which declares the setuptools.build.meta PEP-517 backend. - The PyPi package name (defaults to PN without the python3- prefix), so there is no need to set PYPI_PACKAGE as pytest-timeout, it is by default. Fix: WARNING: python3-pytest-timeout-2.3.1-r0 do_check_backend: QA Issue: inherits setuptools3 but has pyproject.toml with setuptools.build_meta, use the correct class [pep517-backend] Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-timeout_2.3.1.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-timeout_2.3.1.bb b/meta-python/recipes-devtools/python/python3-pytest-timeout_2.3.1.bb
index b56c26aad..fe9d814c0 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-timeout_2.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-timeout_2.3.1.bb
@@ -3,10 +3,8 @@ HOMEPAGE = "https://github.com/pytest-dev/pytest-timeout/"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d8048cd156eda3df2e7f111b0ae9ceff" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=d8048cd156eda3df2e7f111b0ae9ceff"
5 5
6PYPI_PACKAGE = "pytest-timeout"
7
8SRC_URI[sha256sum] = "12397729125c6ecbdaca01035b9e5239d4db97352320af155b3f5de1ba5165d9" 6SRC_URI[sha256sum] = "12397729125c6ecbdaca01035b9e5239d4db97352320af155b3f5de1ba5165d9"
9 7
10inherit pypi setuptools3 8inherit pypi python_setuptools_build_meta
11 9
12RDEPENDS:${PN} = "python3-pytest" 10RDEPENDS:${PN} = "python3-pytest"