summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-08-09 19:31:00 +0300
committerKhem Raj <raj.khem@gmail.com>2024-08-10 15:57:57 -0700
commit197c1020ca6b2ad4a37e0e4450ca62d2a4bb9277 (patch)
treee8aab058467b31f6a2c15c88d0ccbdc2c3a82a11 /meta-python/recipes-devtools
parentf6bf37fcd657f0507c5d3c2892fcd399a369ce96 (diff)
downloadmeta-openembedded-197c1020ca6b2ad4a37e0e4450ca62d2a4bb9277.tar.gz
python3-greenlet: switch to PEP-517 build backend
- The project has a proper pyproject.toml which declares the setuptools.build.meta PEP-517 backend. - python3-greenlet was supposed to be native because of the python3-gevent build. It's python3-gevent's dependency. Fix: WARNING: python3-greenlet-3.0.3-r0 do_check_backend: QA Issue: inherits setuptools3 but has pyproject.toml with setuptools.build_meta, use the correct class [pep517-backend] Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-greenlet_3.0.3.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-greenlet_3.0.3.bb b/meta-python/recipes-devtools/python/python3-greenlet_3.0.3.bb
index abd6c49ca..a79db0049 100644
--- a/meta-python/recipes-devtools/python/python3-greenlet_3.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-greenlet_3.0.3.bb
@@ -6,4 +6,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e95668d68e4329085c7ab3535e6a7aee \
6 6
7SRC_URI[sha256sum] = "43374442353259554ce33599da8b692d5aa96f8976d567d4badf263371fbe491" 7SRC_URI[sha256sum] = "43374442353259554ce33599da8b692d5aa96f8976d567d4badf263371fbe491"
8 8
9inherit pypi setuptools3 9inherit pypi python_setuptools_build_meta
10
11BBCLASSEXTEND = "native nativesdk"