diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-12-14 16:48:12 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-12-14 10:01:50 -0800 |
commit | 02e05067e82646b9b6e9ea44d491a6c859427b1f (patch) | |
tree | 81d3c6781a43f672b41ab3da4d261ba83ebe4d1c /meta-python/recipes-devtools | |
parent | b0bc64e930851dacbe9ec8f46abf0aa0bb6864ca (diff) | |
download | meta-openembedded-02e05067e82646b9b6e9ea44d491a6c859427b1f.tar.gz |
python3-bitarray: upgrade 2.8.3 -> 2.8.5
Changelog:
============
* speedup unaligned copies by always using word shifts (in combination
with builtin byte swap 64 when available) when bit-endianness and
machine byte-order are opposite
* add 'HAVE_BUILTIN_BSWAP64' to header
* avoid misaligned pointers when casting to '(uint64_t *)'
* add tests
* simplify 'copy_n()' (remove special cases), see #d2d6fd53
* add [word shift example C program](../examples/shift_r8.c),
and simplify 'shift_r8()'
* improve documentation and testing
* add [roadmap](https://github.com/ilanschnell/bitarray#roadmap)
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-bitarray_2.8.5.bb (renamed from meta-python/recipes-devtools/python/python3-bitarray_2.8.3.bb) | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_2.8.3.bb b/meta-python/recipes-devtools/python/python3-bitarray_2.8.5.bb index acacdab6d..5047784ab 100644 --- a/meta-python/recipes-devtools/python/python3-bitarray_2.8.3.bb +++ b/meta-python/recipes-devtools/python/python3-bitarray_2.8.5.bb | |||
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/ilanschnell/bitarray" | |||
4 | LICENSE = "PSF-2.0" | 4 | LICENSE = "PSF-2.0" |
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=2ad702cdcd49e8d2ac01d7e7d0810d2d" | 5 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=2ad702cdcd49e8d2ac01d7e7d0810d2d" |
6 | 6 | ||
7 | SRC_URI[sha256sum] = "e15587b2bdf18d32eb3ba25f5f5a51bedd0dc06b3112a4c53dab5e7753bc6588" | 7 | SRC_URI[sha256sum] = "b7564fd218cc4479f7f0106d341e096f78907b47865aeeff702c807df1927c01" |
8 | 8 | ||
9 | inherit setuptools3 pypi | 9 | inherit setuptools3 pypi |
10 | 10 | ||