diff options
author | Dominic Sacré <dominic.sacre@gmx.de> | 2015-08-24 17:27:54 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-08-31 19:17:07 +0200 |
commit | 29aa76af6579f95340488d2b5ba6fb66f8ea2771 (patch) | |
tree | a24149330f15ca206c53b85c8e58604ef1922354 /meta-python/recipes-devtools | |
parent | b13250198de5e1a5461e3e8079cf858cc6a084a3 (diff) | |
download | meta-openembedded-29aa76af6579f95340488d2b5ba6fb66f8ea2771.tar.gz |
python3-cython: Add new recipe
Use a common .inc file for the python-cython and python3-cython recipes.
Add suffix '3' to scripts in ${bindir} to avoid conflict between the two
packages.
Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
3 files changed, 40 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python-cython.inc b/meta-python/recipes-devtools/python/python-cython.inc new file mode 100644 index 000000000..6c8b084c1 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-cython.inc | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "Cython is a language specially designed for writing Python extension modules. \ | ||
2 | It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \ | ||
3 | and the messy, low-level world of C." | ||
4 | SECTION = "devel/python" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa" | ||
7 | SRCNAME = "Cython" | ||
8 | BBCLASSEXTEND = "native" | ||
9 | |||
10 | SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz" | ||
11 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
12 | |||
13 | SRC_URI[md5sum] = "db3c5b365e1c3f71c7cd90e96473a3ab" | ||
14 | SRC_URI[sha256sum] = "bdfd12d6a2a2e34b9a1bbc1af5a772cabdeedc3851703d249a52dcda8378018a" | ||
15 | |||
16 | RDEPENDS_${PN} += "\ | ||
17 | ${PYTHON_PN}-netserver \ | ||
18 | ${PYTHON_PN}-subprocess \ | ||
19 | ${PYTHON_PN}-shell \ | ||
20 | " | ||
21 | RDEPENDS_${PN}_class-native = "" | ||
diff --git a/meta-python/recipes-devtools/python/python-cython_0.23.1.bb b/meta-python/recipes-devtools/python/python-cython_0.23.1.bb index a0babc893..6be0b1e30 100644 --- a/meta-python/recipes-devtools/python/python-cython_0.23.1.bb +++ b/meta-python/recipes-devtools/python/python-cython_0.23.1.bb | |||
@@ -1,24 +1,6 @@ | |||
1 | DESCRIPTION = "Cython is a language specially designed for writing Python extension modules. \ | ||
2 | It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \ | ||
3 | and the messy, low-level world of C." | ||
4 | SECTION = "devel/python" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa" | ||
7 | SRCNAME = "Cython" | ||
8 | BBCLASSEXTEND = "native" | ||
9 | |||
10 | SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz" | ||
11 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
12 | |||
13 | SRC_URI[md5sum] = "db3c5b365e1c3f71c7cd90e96473a3ab" | ||
14 | SRC_URI[sha256sum] = "bdfd12d6a2a2e34b9a1bbc1af5a772cabdeedc3851703d249a52dcda8378018a" | ||
15 | |||
16 | inherit setuptools | 1 | inherit setuptools |
2 | require python-cython.inc | ||
17 | 3 | ||
18 | RDEPENDS_${PN} += "\ | 4 | RDEPENDS_${PN} += "\ |
19 | python-distribute \ | 5 | python-distribute \ |
20 | python-netserver \ | ||
21 | python-subprocess \ | ||
22 | python-shell \ | ||
23 | " | 6 | " |
24 | RDEPENDS_${PN}_class-native = "" | ||
diff --git a/meta-python/recipes-devtools/python/python3-cython_0.23.1.bb b/meta-python/recipes-devtools/python/python3-cython_0.23.1.bb new file mode 100644 index 000000000..2ce6bdbd6 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-cython_0.23.1.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-cython.inc | ||
3 | |||
4 | RDEPENDS_${PN} += "\ | ||
5 | python3-setuptools \ | ||
6 | " | ||
7 | |||
8 | # running build_ext a second time during install fails, because Python | ||
9 | # would then attempt to import cythonized modules built for the target | ||
10 | # architecture. | ||
11 | DISTUTILS_INSTALL_ARGS += "--skip-build" | ||
12 | |||
13 | do_install_append() { | ||
14 | # rename scripts that would conflict with the Python 2 build of Cython | ||
15 | mv ${D}${bindir}/cython ${D}${bindir}/cython3 | ||
16 | mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3 | ||
17 | mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3 | ||
18 | } | ||