diff options
author | Bill Randle <bill.randle@gmail.com> | 2017-12-07 21:45:39 -0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-12-22 19:43:38 -0800 |
commit | dd38e0e3f2666acbac5863df648124e9669817bc (patch) | |
tree | 08afa7426bcd63c15177e7d985f408030fd0db18 /meta-python/recipes-devtools | |
parent | acfb8417e370d017e7307872e61564deeda76a13 (diff) | |
download | meta-openembedded-dd38e0e3f2666acbac5863df648124e9669817bc.tar.gz |
python-flask-bootstrap: move core of recipe to a .inc file
Signed-off-by: Bill Randle <bill.randle@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python-flask-bootstrap.inc | 14 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-flask-bootstrap_3.3.7.1.bb | 16 |
2 files changed, 15 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-bootstrap.inc b/meta-python/recipes-devtools/python/python-flask-bootstrap.inc new file mode 100644 index 000000000..0723b9738 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-flask-bootstrap.inc | |||
@@ -0,0 +1,14 @@ | |||
1 | DESCRIPTION = "An extension that includes Bootstrap in your project, without any boilerplate code." | ||
2 | LICENSE = "BSD" | ||
3 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a03749709f06118a17349deb5a210619" | ||
4 | |||
5 | SRC_URI[md5sum] = "e40d50f5c5b6438c1c6200a6f2871f81" | ||
6 | SRC_URI[sha256sum] = "cb08ed940183f6343a64e465e83b3a3f13c53e1baabb8d72b5da4545ef123ac8" | ||
7 | |||
8 | PYPI_PACKAGE = "Flask-Bootstrap" | ||
9 | |||
10 | RDEPENDS_${PN} += "\ | ||
11 | ${PYTHON_PN}-dominate \ | ||
12 | ${PYTHON_PN}-flask \ | ||
13 | ${PYTHON_PN}-visitor \ | ||
14 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-flask-bootstrap_3.3.7.1.bb b/meta-python/recipes-devtools/python/python-flask-bootstrap_3.3.7.1.bb index 2b2a6f9bd..eeaade9a8 100644 --- a/meta-python/recipes-devtools/python/python-flask-bootstrap_3.3.7.1.bb +++ b/meta-python/recipes-devtools/python/python-flask-bootstrap_3.3.7.1.bb | |||
@@ -1,16 +1,2 @@ | |||
1 | DESCRIPTION = "An extension that includes Bootstrap in your project, without any boilerplate code." | ||
2 | LICENSE = "BSD" | ||
3 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a03749709f06118a17349deb5a210619" | ||
4 | |||
5 | SRC_URI[md5sum] = "e40d50f5c5b6438c1c6200a6f2871f81" | ||
6 | SRC_URI[sha256sum] = "cb08ed940183f6343a64e465e83b3a3f13c53e1baabb8d72b5da4545ef123ac8" | ||
7 | |||
8 | PYPI_PACKAGE = "Flask-Bootstrap" | ||
9 | |||
10 | inherit pypi setuptools | 1 | inherit pypi setuptools |
11 | 2 | require python-flask-bootstrap.inc | |
12 | RDEPENDS_${PN} += "\ | ||
13 | ${PYTHON_PN}-dominate \ | ||
14 | ${PYTHON_PN}-flask \ | ||
15 | ${PYTHON_PN}-visitor \ | ||
16 | " | ||