diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2019-08-12 09:06:42 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-08-12 09:11:01 -0700 |
commit | 8b4b7567a69610b9e04acbd1c9a2b8e1d16f37f8 (patch) | |
tree | 480d914394b4feabc0b18c76d7ba7f50c49d652b /meta-python/recipes-devtools | |
parent | 7cede6b863fc0de245b4b7f0071ac38d2059b0af (diff) | |
download | meta-openembedded-8b4b7567a69610b9e04acbd1c9a2b8e1d16f37f8.tar.gz |
python3-twofish: Fix missing return statements in module stubs
* fixes build with -Werror=return-type
twofish.c: In function 'init_twofish':
twofish.c:45:1: error: control reaches end of non-void function [-Werror=return-type]
45 | PyMODINIT_FUNC init_twofish(void) { }
| ^~~~~~~~~~~~~~
twofish.c: In function 'PyInit__twofish':
twofish.c:46:1: error: control reaches end of non-void function [-Werror=return-type]
46 | PyMODINIT_FUNC PyInit__twofish(void) { }
| ^~~~~~~~~~~~~~
cc1: some warnings being treated as errors
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch | 38 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb | 2 |
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch b/meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch new file mode 100644 index 000000000..c25b2457e --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 5704610f4b3aed5210e9c5b7c05ff8b5b2364c9c Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Mon, 12 Aug 2019 08:18:21 +0000 | ||
4 | Subject: [PATCH] Fix missing return statements in module stubs | ||
5 | |||
6 | * fixes build with -Werror=return-type | ||
7 | twofish.c: In function 'init_twofish': | ||
8 | twofish.c:45:1: error: control reaches end of non-void function [-Werror=return-type] | ||
9 | 45 | PyMODINIT_FUNC init_twofish(void) { } | ||
10 | | ^~~~~~~~~~~~~~ | ||
11 | twofish.c: In function 'PyInit__twofish': | ||
12 | twofish.c:46:1: error: control reaches end of non-void function [-Werror=return-type] | ||
13 | 46 | PyMODINIT_FUNC PyInit__twofish(void) { } | ||
14 | | ^~~~~~~~~~~~~~ | ||
15 | cc1: some warnings being treated as errors | ||
16 | |||
17 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
18 | |||
19 | Upstream-Status: Submitted [https://github.com/keybase/python-twofish/pull/6] | ||
20 | --- | ||
21 | twofish.c | 4 ++-- | ||
22 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
23 | |||
24 | diff --git a/twofish.c b/twofish.c | ||
25 | index e324c34..d4487d8 100644 | ||
26 | --- a/twofish.c | ||
27 | +++ b/twofish.c | ||
28 | @@ -42,5 +42,5 @@ DL_EXPORT(void) exp_Twofish_decrypt(Twofish_key * xkey, uint8_t c[16], uint8_t p | ||
29 | We need a stub init_twofish function so the module will link as a proper module. | ||
30 | Do not import _twofish from python; it will not work since _twofish is not a *real* module | ||
31 | */ | ||
32 | -PyMODINIT_FUNC init_twofish(void) { } | ||
33 | -PyMODINIT_FUNC PyInit__twofish(void) { } | ||
34 | +PyMODINIT_FUNC init_twofish(void) { return NULL; } | ||
35 | +PyMODINIT_FUNC PyInit__twofish(void) { return NULL; } | ||
36 | -- | ||
37 | 2.17.1 | ||
38 | |||
diff --git a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb index e593f6f21..7b8eb2ef0 100644 --- a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb +++ b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb | |||
@@ -1,2 +1,4 @@ | |||
1 | require python-twofish.inc | 1 | require python-twofish.inc |
2 | inherit setuptools3 | 2 | inherit setuptools3 |
3 | |||
4 | SRC_URI += "file://0001-Fix-missing-return-statements-in-module-stubs.patch" | ||