diff options
author | Derek Straka <derek@asterius.io> | 2020-04-04 14:20:57 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-04-05 10:38:14 -0700 |
commit | 055eb129964f2612fbdf16376ef47358e2821e33 (patch) | |
tree | 659dbee1ade6d2b9878f1d8cbb908ddd2baccbe5 /meta-python/recipes-devtools | |
parent | df56d64c2809b7b86e80fb89f89bcc68607e5ed4 (diff) | |
download | meta-openembedded-055eb129964f2612fbdf16376ef47358e2821e33.tar.gz |
python-pyyaml: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyyaml.inc | 18 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb | 20 |
2 files changed, 18 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyyaml.inc b/meta-python/recipes-devtools/python/python-pyyaml.inc deleted file mode 100644 index aede58530..000000000 --- a/meta-python/recipes-devtools/python/python-pyyaml.inc +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | SUMMARY = "Python support for YAML" | ||
2 | HOMEPAGE = "http://www.pyyaml.org" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a76b4c69bfcf82313bbdc0393b04438a" | ||
6 | DEPENDS = "libyaml ${PYTHON_PN}-cython-native ${PYTHON_PN}" | ||
7 | |||
8 | PYPI_PACKAGE = "PyYAML" | ||
9 | inherit pypi | ||
10 | |||
11 | SRC_URI[md5sum] = "adbb0d336b509d6472d3b095a0f1cf30" | ||
12 | SRC_URI[sha256sum] = "e9f45bd5b92c7974e59bcd2dcc8631a6b6cc380a904725fce7bc08872e691615" | ||
13 | |||
14 | RDEPENDS_${PN} += "\ | ||
15 | ${PYTHON_PN}-datetime \ | ||
16 | " | ||
17 | |||
18 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb b/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb index 470aca608..b5425b8c9 100644 --- a/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb +++ b/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb | |||
@@ -1,2 +1,18 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "Python support for YAML" |
2 | require python-pyyaml.inc | 2 | HOMEPAGE = "http://www.pyyaml.org" |
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a76b4c69bfcf82313bbdc0393b04438a" | ||
6 | DEPENDS = "libyaml ${PYTHON_PN}-cython-native ${PYTHON_PN}" | ||
7 | |||
8 | PYPI_PACKAGE = "PyYAML" | ||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | SRC_URI[md5sum] = "adbb0d336b509d6472d3b095a0f1cf30" | ||
12 | SRC_URI[sha256sum] = "e9f45bd5b92c7974e59bcd2dcc8631a6b6cc380a904725fce7bc08872e691615" | ||
13 | |||
14 | RDEPENDS_${PN} += "\ | ||
15 | ${PYTHON_PN}-datetime \ | ||
16 | " | ||
17 | |||
18 | BBCLASSEXTEND = "native nativesdk" | ||