summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 14:20:57 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commit055eb129964f2612fbdf16376ef47358e2821e33 (patch)
tree659dbee1ade6d2b9878f1d8cbb908ddd2baccbe5 /meta-python/recipes-devtools
parentdf56d64c2809b7b86e80fb89f89bcc68607e5ed4 (diff)
downloadmeta-openembedded-055eb129964f2612fbdf16376ef47358e2821e33.tar.gz
python-pyyaml: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pyyaml.inc18
-rw-r--r--meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb20
2 files changed, 18 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyyaml.inc b/meta-python/recipes-devtools/python/python-pyyaml.inc
deleted file mode 100644
index aede58530..000000000
--- a/meta-python/recipes-devtools/python/python-pyyaml.inc
+++ /dev/null
@@ -1,18 +0,0 @@
1SUMMARY = "Python support for YAML"
2HOMEPAGE = "http://www.pyyaml.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a76b4c69bfcf82313bbdc0393b04438a"
6DEPENDS = "libyaml ${PYTHON_PN}-cython-native ${PYTHON_PN}"
7
8PYPI_PACKAGE = "PyYAML"
9inherit pypi
10
11SRC_URI[md5sum] = "adbb0d336b509d6472d3b095a0f1cf30"
12SRC_URI[sha256sum] = "e9f45bd5b92c7974e59bcd2dcc8631a6b6cc380a904725fce7bc08872e691615"
13
14RDEPENDS_${PN} += "\
15 ${PYTHON_PN}-datetime \
16"
17
18BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb b/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb
index 470aca608..b5425b8c9 100644
--- a/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pyyaml_5.3.bb
@@ -1,2 +1,18 @@
1inherit setuptools3 1SUMMARY = "Python support for YAML"
2require python-pyyaml.inc 2HOMEPAGE = "http://www.pyyaml.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a76b4c69bfcf82313bbdc0393b04438a"
6DEPENDS = "libyaml ${PYTHON_PN}-cython-native ${PYTHON_PN}"
7
8PYPI_PACKAGE = "PyYAML"
9inherit pypi setuptools3
10
11SRC_URI[md5sum] = "adbb0d336b509d6472d3b095a0f1cf30"
12SRC_URI[sha256sum] = "e9f45bd5b92c7974e59bcd2dcc8631a6b6cc380a904725fce7bc08872e691615"
13
14RDEPENDS_${PN} += "\
15 ${PYTHON_PN}-datetime \
16"
17
18BBCLASSEXTEND = "native nativesdk"