diff options
author | Derek Straka <derek@asterius.io> | 2018-01-21 11:20:29 -0500 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-01-26 17:28:11 -0800 |
commit | 87cc37b07209002d52e00693d74748fad9a5e8a2 (patch) | |
tree | 1ca4922b6f18a4052ef94667691e6a4e29455394 /meta-python/recipes-devtools/python | |
parent | 1bb9de8f54d5bcb0e0a47f3494e3b17bb39e714e (diff) | |
download | meta-openembedded-87cc37b07209002d52e00693d74748fad9a5e8a2.tar.gz |
Remove deprecated python3-re from the RDEPENDS
The python3-re package was removed as part of the migration to the
json manifest file. The functionality is now part of core
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
16 files changed, 16 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python-astroid.inc b/meta-python/recipes-devtools/python/python-astroid.inc index 971aaf47d..a71762c50 100644 --- a/meta-python/recipes-devtools/python/python-astroid.inc +++ b/meta-python/recipes-devtools/python/python-astroid.inc | |||
@@ -22,7 +22,6 @@ RDEPENDS_${PN}_class-target += "\ | |||
22 | ${PYTHON_PN}-six \ | 22 | ${PYTHON_PN}-six \ |
23 | ${PYTHON_PN}-subprocess \ | 23 | ${PYTHON_PN}-subprocess \ |
24 | ${PYTHON_PN}-wrapt \ | 24 | ${PYTHON_PN}-wrapt \ |
25 | ${PYTHON_PN}-re \ | ||
26 | ${PYTHON_PN}-setuptools \ | 25 | ${PYTHON_PN}-setuptools \ |
27 | " | 26 | " |
28 | 27 | ||
diff --git a/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb b/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb index 3ced19a09..42208bcb1 100644 --- a/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb +++ b/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb | |||
@@ -5,5 +5,6 @@ RDEPENDS_${PN}_class-target += " \ | |||
5 | ${PYTHON_PN}-enum34 \ | 5 | ${PYTHON_PN}-enum34 \ |
6 | ${PYTHON_PN}-backports-functools-lru-cache \ | 6 | ${PYTHON_PN}-backports-functools-lru-cache \ |
7 | ${PYTHON_PN}-importlib \ | 7 | ${PYTHON_PN}-importlib \ |
8 | ${PYTHON_PN}-re \ | ||
8 | ${PYTHON_PN}-singledispatch \ | 9 | ${PYTHON_PN}-singledispatch \ |
9 | " | 10 | " |
diff --git a/meta-python/recipes-devtools/python/python-gevent.inc b/meta-python/recipes-devtools/python/python-gevent.inc index 8889cfb5a..13513f219 100644 --- a/meta-python/recipes-devtools/python/python-gevent.inc +++ b/meta-python/recipes-devtools/python/python-gevent.inc | |||
@@ -11,7 +11,6 @@ DEPENDS += "${PYTHON_PN}-greenlet" | |||
11 | RDEPENDS_${PN} = "${PYTHON_PN}-greenlet \ | 11 | RDEPENDS_${PN} = "${PYTHON_PN}-greenlet \ |
12 | ${PYTHON_PN}-mime \ | 12 | ${PYTHON_PN}-mime \ |
13 | ${PYTHON_PN}-pprint \ | 13 | ${PYTHON_PN}-pprint \ |
14 | ${PYTHON_PN}-re \ | ||
15 | " | 14 | " |
16 | 15 | ||
17 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-gevent:" | 16 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-gevent:" |
diff --git a/meta-python/recipes-devtools/python/python-gevent_1.2.2.bb b/meta-python/recipes-devtools/python/python-gevent_1.2.2.bb index f357c9527..f13bfd7b7 100644 --- a/meta-python/recipes-devtools/python/python-gevent_1.2.2.bb +++ b/meta-python/recipes-devtools/python/python-gevent_1.2.2.bb | |||
@@ -1,3 +1,4 @@ | |||
1 | require python-gevent.inc | 1 | require python-gevent.inc |
2 | inherit setuptools | 2 | inherit setuptools |
3 | 3 | ||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-re" | ||
diff --git a/meta-python/recipes-devtools/python/python-jinja2.inc b/meta-python/recipes-devtools/python/python-jinja2.inc index cd50d931b..72562fb53 100644 --- a/meta-python/recipes-devtools/python/python-jinja2.inc +++ b/meta-python/recipes-devtools/python/python-jinja2.inc | |||
@@ -8,7 +8,7 @@ SRC_URI[md5sum] = "61ef1117f945486472850819b8d1eb3d" | |||
8 | SRC_URI[sha256sum] = "f84be1bb0040caca4cea721fcbbbbd61f9be9464ca236387158b0feea01914a4" | 8 | SRC_URI[sha256sum] = "f84be1bb0040caca4cea721fcbbbbd61f9be9464ca236387158b0feea01914a4" |
9 | 9 | ||
10 | RDEPENDS_${PN} += "${PYTHON_PN}-io ${PYTHON_PN}-pickle ${PYTHON_PN}-crypt \ | 10 | RDEPENDS_${PN} += "${PYTHON_PN}-io ${PYTHON_PN}-pickle ${PYTHON_PN}-crypt \ |
11 | ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-re ${PYTHON_PN}-textutils \ | 11 | ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-textutils \ |
12 | ${PYTHON_PN}-lang ${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \ | 12 | ${PYTHON_PN}-lang ${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \ |
13 | ${PYTHON_PN}-json ${PYTHON_PN}-threading ${PYTHON_PN}-numbers" | 13 | ${PYTHON_PN}-json ${PYTHON_PN}-threading ${PYTHON_PN}-numbers" |
14 | 14 | ||
diff --git a/meta-python/recipes-devtools/python/python-jinja2_2.10.bb b/meta-python/recipes-devtools/python/python-jinja2_2.10.bb index ec8e7ed2d..19b2bfaf6 100644 --- a/meta-python/recipes-devtools/python/python-jinja2_2.10.bb +++ b/meta-python/recipes-devtools/python/python-jinja2_2.10.bb | |||
@@ -1,2 +1,4 @@ | |||
1 | inherit pypi setuptools | 1 | inherit pypi setuptools |
2 | require python-jinja2.inc | 2 | require python-jinja2.inc |
3 | |||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-re" | ||
diff --git a/meta-python/recipes-devtools/python/python-jsonpatch.inc b/meta-python/recipes-devtools/python/python-jsonpatch.inc index 838dbe332..e559fb1eb 100644 --- a/meta-python/recipes-devtools/python/python-jsonpatch.inc +++ b/meta-python/recipes-devtools/python/python-jsonpatch.inc | |||
@@ -8,5 +8,5 @@ inherit pypi | |||
8 | SRC_URI[md5sum] = "0b20d819daf120ed3fef3be608f2ce18" | 8 | SRC_URI[md5sum] = "0b20d819daf120ed3fef3be608f2ce18" |
9 | SRC_URI[sha256sum] = "11f5ffdf543a83047a2f54ac28f8caad7f34724cb1ea26b27547fd974f1a2153" | 9 | SRC_URI[sha256sum] = "11f5ffdf543a83047a2f54ac28f8caad7f34724cb1ea26b27547fd974f1a2153" |
10 | 10 | ||
11 | RDEPENDS_${PN} += "${PYTHON_PN}-json ${PYTHON_PN}-jsonpointer ${PYTHON_PN}-netclient ${PYTHON_PN}-re ${PYTHON_PN}-stringold" | 11 | RDEPENDS_${PN} += "${PYTHON_PN}-json ${PYTHON_PN}-jsonpointer ${PYTHON_PN}-netclient ${PYTHON_PN}-stringold" |
12 | 12 | ||
diff --git a/meta-python/recipes-devtools/python/python-jsonpatch_1.21.bb b/meta-python/recipes-devtools/python/python-jsonpatch_1.21.bb index e45699a6d..90cd31802 100644 --- a/meta-python/recipes-devtools/python/python-jsonpatch_1.21.bb +++ b/meta-python/recipes-devtools/python/python-jsonpatch_1.21.bb | |||
@@ -1,2 +1,4 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-jsonpatch.inc | 2 | require python-jsonpatch.inc |
3 | |||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-re" | ||
diff --git a/meta-python/recipes-devtools/python/python-jsonpointer.inc b/meta-python/recipes-devtools/python/python-jsonpointer.inc index e678198cc..5381fbe23 100644 --- a/meta-python/recipes-devtools/python/python-jsonpointer.inc +++ b/meta-python/recipes-devtools/python/python-jsonpointer.inc | |||
@@ -10,5 +10,4 @@ SRC_URI[sha256sum] = "c681af823545c731b7b38aedd5d4eee4c5eff87bc0f25e0ff25444a418 | |||
10 | 10 | ||
11 | RDEPENDS_${PN} += " \ | 11 | RDEPENDS_${PN} += " \ |
12 | ${PYTHON_PN}-json \ | 12 | ${PYTHON_PN}-json \ |
13 | ${PYTHON_PN}-re \ | ||
14 | " | 13 | " |
diff --git a/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb b/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb index 064bd6c5d..e13a776ad 100644 --- a/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb +++ b/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb | |||
@@ -1,2 +1,4 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-jsonpointer.inc | 2 | require python-jsonpointer.inc |
3 | |||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-re" | ||
diff --git a/meta-python/recipes-devtools/python/python-jsonschema.inc b/meta-python/recipes-devtools/python/python-jsonschema.inc index db57c69a4..b602b27b9 100644 --- a/meta-python/recipes-devtools/python/python-jsonschema.inc +++ b/meta-python/recipes-devtools/python/python-jsonschema.inc | |||
@@ -16,7 +16,6 @@ RDEPENDS_${PN} += " \ | |||
16 | ${PYTHON_PN}-numbers \ | 16 | ${PYTHON_PN}-numbers \ |
17 | ${PYTHON_PN}-pkgutil \ | 17 | ${PYTHON_PN}-pkgutil \ |
18 | ${PYTHON_PN}-pprint \ | 18 | ${PYTHON_PN}-pprint \ |
19 | ${PYTHON_PN}-re \ | ||
20 | ${PYTHON_PN}-rfc3987 \ | 19 | ${PYTHON_PN}-rfc3987 \ |
21 | ${PYTHON_PN}-shell \ | 20 | ${PYTHON_PN}-shell \ |
22 | ${PYTHON_PN}-strict-rfc3339 \ | 21 | ${PYTHON_PN}-strict-rfc3339 \ |
diff --git a/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb b/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb index 3bb522018..55cbb2020 100644 --- a/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb +++ b/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb | |||
@@ -5,4 +5,5 @@ RDEPENDS_${PN} += " \ | |||
5 | ${PYTHON_PN}-argparse \ | 5 | ${PYTHON_PN}-argparse \ |
6 | ${PYTHON_PN}-contextlib \ | 6 | ${PYTHON_PN}-contextlib \ |
7 | ${PYTHON_PN}-functools32 \ | 7 | ${PYTHON_PN}-functools32 \ |
8 | ${PYTHON_PN}-re \ | ||
8 | " | 9 | " |
diff --git a/meta-python/recipes-devtools/python/python-markupsafe.inc b/meta-python/recipes-devtools/python/python-markupsafe.inc index e50f8ce38..927f84452 100644 --- a/meta-python/recipes-devtools/python/python-markupsafe.inc +++ b/meta-python/recipes-devtools/python/python-markupsafe.inc | |||
@@ -9,4 +9,4 @@ SRC_URI[sha256sum] = "a6be69091dac236ea9c6bc7d012beab42010fa914c459791d627dad491 | |||
9 | PYPI_PACKAGE = "MarkupSafe" | 9 | PYPI_PACKAGE = "MarkupSafe" |
10 | inherit pypi | 10 | inherit pypi |
11 | 11 | ||
12 | RDEPENDS_${PN} += "${PYTHON_PN}-re ${PYTHON_PN}-stringold" | 12 | RDEPENDS_${PN} += "${PYTHON_PN}-stringold" |
diff --git a/meta-python/recipes-devtools/python/python-markupsafe_1.0.bb b/meta-python/recipes-devtools/python/python-markupsafe_1.0.bb index 5c9884b9f..05bbe8a35 100644 --- a/meta-python/recipes-devtools/python/python-markupsafe_1.0.bb +++ b/meta-python/recipes-devtools/python/python-markupsafe_1.0.bb | |||
@@ -1,4 +1,6 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-markupsafe.inc | 2 | require python-markupsafe.inc |
3 | 3 | ||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-re" | ||
5 | |||
4 | BBCLASSEXTEND = "native" | 6 | BBCLASSEXTEND = "native" |
diff --git a/meta-python/recipes-devtools/python/python-simplejson.inc b/meta-python/recipes-devtools/python/python-simplejson.inc index 95df3f356..e28d51859 100644 --- a/meta-python/recipes-devtools/python/python-simplejson.inc +++ b/meta-python/recipes-devtools/python/python-simplejson.inc | |||
@@ -10,7 +10,6 @@ SRC_URI[sha256sum] = "4c4ecf20e054716cc1e5a81cadc44d3f4027108d8dd0861d8b1e3bd7a3 | |||
10 | inherit pypi | 10 | inherit pypi |
11 | 11 | ||
12 | RDEPENDS_${PN} += "\ | 12 | RDEPENDS_${PN} += "\ |
13 | ${PYTHON_PN}-re \ | ||
14 | ${PYTHON_PN}-io \ | 13 | ${PYTHON_PN}-io \ |
15 | ${PYTHON_PN}-netserver \ | 14 | ${PYTHON_PN}-netserver \ |
16 | ${PYTHON_PN}-numbers \ | 15 | ${PYTHON_PN}-numbers \ |
diff --git a/meta-python/recipes-devtools/python/python-simplejson_3.13.2.bb b/meta-python/recipes-devtools/python/python-simplejson_3.13.2.bb index e33edfeba..24ad9a960 100644 --- a/meta-python/recipes-devtools/python/python-simplejson_3.13.2.bb +++ b/meta-python/recipes-devtools/python/python-simplejson_3.13.2.bb | |||
@@ -1,2 +1,4 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-simplejson.inc | 2 | require python-simplejson.inc |
3 | |||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-re" | ||