diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2017-08-25 16:40:42 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-28 11:06:07 +0200 |
commit | 5cdc74cddfbe56e680c9f8a79768c791cc7794bc (patch) | |
tree | bd2219257b52286f78b53d8942af6a80f7a15dc6 /meta-python/recipes-devtools/python | |
parent | eb5163cfbefad3a6131b63f117a9fd389047def1 (diff) | |
download | meta-openembedded-5cdc74cddfbe56e680c9f8a79768c791cc7794bc.tar.gz |
python-beautifulsoup4: add new recipe for both python2 and python3
Beautiful Soup sits atop an HTML or XML parser,
providing Pythonic idioms for iterating, searching,
and modifying the parse tree.
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-beautifulsoup4.inc b/meta-python/recipes-devtools/python/python-beautifulsoup4.inc new file mode 100644 index 000000000..d60d987ca --- /dev/null +++ b/meta-python/recipes-devtools/python/python-beautifulsoup4.inc | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "Screen-scraping library" | ||
2 | HOMEPAGE = " https://www.crummy.com/software/BeautifulSoup/bs4" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=f2d38d8a40bf73fd4b3d16ca2e5882d1" | ||
5 | |||
6 | SRC_URI[md5sum] = "c17714d0f91a23b708a592cb3c697728" | ||
7 | SRC_URI[sha256sum] = "808b6ac932dccb0a4126558f7dfdcf41710dd44a4ef497a0bb59a77f9f078e89" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | RDEPENDS_${PN}_class-target = "\ | ||
12 | ${PYTHON_PN}-core \ | ||
13 | ${PYTHON_PN}-html5lib \ | ||
14 | ${PYTHON_PN}-lxml \ | ||
15 | " | ||
16 | |||
17 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-beautifulsoup4_4.6.0.bb b/meta-python/recipes-devtools/python/python-beautifulsoup4_4.6.0.bb new file mode 100644 index 000000000..907285ac1 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-beautifulsoup4_4.6.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-beautifulsoup4.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-beautifulsoup4_4.6.0.bb b/meta-python/recipes-devtools/python/python3-beautifulsoup4_4.6.0.bb new file mode 100644 index 000000000..d98df11e3 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-beautifulsoup4_4.6.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-beautifulsoup4.inc | ||