diff options
author | Daniela Plascencia <daniela.plascencia@linux.intel.com> | 2017-06-20 12:20:02 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-06-22 16:03:00 +0200 |
commit | 6e36914607f5174128c5161667c9e51ff1f451a8 (patch) | |
tree | ee0ace4acec965b462b46d69d34dc05ad6ecbd0a /meta-python/recipes-devtools/python | |
parent | 021844a31fb7081da8213338288596df0c281fe2 (diff) | |
download | meta-openembedded-6e36914607f5174128c5161667c9e51ff1f451a8.tar.gz |
python-pylint: adds Python3 support
Extend the recipe for Python3 support.
Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 36 insertions, 43 deletions
diff --git a/meta-python/recipes-devtools/python/python-pylint.inc b/meta-python/recipes-devtools/python/python-pylint.inc new file mode 100644 index 000000000..18be8a191 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pylint.inc | |||
@@ -0,0 +1,31 @@ | |||
1 | SUMMARY="Pylint is a Python source code analyzer" | ||
2 | HOMEPAGE= "http://www.pylint.org/" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
5 | |||
6 | SRC_URI[md5sum] = "31da2185bf59142479e4fa16d8a9e347" | ||
7 | SRC_URI[sha256sum] = "a673984a8dd78e4a8b8cfdee5359a1309d833cf38405008f4a249994a8456719" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" | ||
12 | |||
13 | RDEPENDS_${PN} += "${PYTHON_PN}-astroid \ | ||
14 | ${PYTHON_PN}-isort \ | ||
15 | ${PYTHON_PN}-numbers \ | ||
16 | ${PYTHON_PN}-shell \ | ||
17 | ${PYTHON_PN}-json \ | ||
18 | ${PYTHON_PN}-pkgutil \ | ||
19 | ${PYTHON_PN}-difflib \ | ||
20 | ${PYTHON_PN}-netserver \ | ||
21 | " | ||
22 | |||
23 | do_install_append(){ | ||
24 | rm ${D}${bindir}/pylint | ||
25 | cat >> ${D}${bindir}/pylint <<EOF | ||
26 | #!/usr/bin/env ${PYTHON_PN} | ||
27 | from pylint import run_pylint | ||
28 | run_pylint() | ||
29 | EOF | ||
30 | chmod 755 ${D}${bindir}/pylint | ||
31 | } | ||
diff --git a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb index f5b4ad052..47ab36a3b 100644 --- a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb +++ b/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb | |||
@@ -1,44 +1,4 @@ | |||
1 | SUMMARY="Pylint is a Python source code analyzer" | 1 | inherit setuptools |
2 | HOMEPAGE= "http://www.pylint.org/" | 2 | require python-pylint.inc |
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
5 | 3 | ||
6 | SRC_URI[md5sum] = "31da2185bf59142479e4fa16d8a9e347" | 4 | RDEPENDS_${PN} += "${PYTHON_PN}-backports-functools-lru-cache" |
7 | SRC_URI[sha256sum] = "a673984a8dd78e4a8b8cfdee5359a1309d833cf38405008f4a249994a8456719" | ||
8 | |||
9 | RDEPENDS_${PN} += "python-codecs \ | ||
10 | python-contextlib \ | ||
11 | python-core \ | ||
12 | python-distutils \ | ||
13 | python-io \ | ||
14 | python-lang \ | ||
15 | python-multiprocessing \ | ||
16 | python-netserver \ | ||
17 | python-numbers \ | ||
18 | python-pickle \ | ||
19 | python-re \ | ||
20 | python-shell \ | ||
21 | python-six \ | ||
22 | python-stringold \ | ||
23 | python-subprocess \ | ||
24 | python-textutils \ | ||
25 | python-unittest \ | ||
26 | python-backports-functools-lru-cache \ | ||
27 | python-setuptools \ | ||
28 | python-astroid \ | ||
29 | python-wrapt \ | ||
30 | python-isort \ | ||
31 | python-lazy-object-proxy \ | ||
32 | " | ||
33 | |||
34 | inherit pypi setuptools | ||
35 | |||
36 | do_install_append(){ | ||
37 | rm ${D}${bindir}/pylint | ||
38 | cat >> ${D}${bindir}/pylint <<EOF | ||
39 | #!/usr/bin/env python | ||
40 | from pylint import run_pylint | ||
41 | run_pylint() | ||
42 | EOF | ||
43 | chmod 755 ${D}${bindir}/pylint | ||
44 | } | ||
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb new file mode 100644 index 000000000..fed65b303 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-pylint.inc | ||