summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDaniela Plascencia <daniela.plascencia@linux.intel.com>2017-06-20 12:20:02 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-22 16:03:00 +0200
commit6e36914607f5174128c5161667c9e51ff1f451a8 (patch)
treeee0ace4acec965b462b46d69d34dc05ad6ecbd0a /meta-python/recipes-devtools/python
parent021844a31fb7081da8213338288596df0c281fe2 (diff)
downloadmeta-openembedded-6e36914607f5174128c5161667c9e51ff1f451a8.tar.gz
python-pylint: adds Python3 support
Extend the recipe for Python3 support. Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pylint.inc31
-rw-r--r--meta-python/recipes-devtools/python/python-pylint_1.6.5.bb46
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb2
3 files changed, 36 insertions, 43 deletions
diff --git a/meta-python/recipes-devtools/python/python-pylint.inc b/meta-python/recipes-devtools/python/python-pylint.inc
new file mode 100644
index 000000000..18be8a191
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pylint.inc
@@ -0,0 +1,31 @@
1SUMMARY="Pylint is a Python source code analyzer"
2HOMEPAGE= "http://www.pylint.org/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
5
6SRC_URI[md5sum] = "31da2185bf59142479e4fa16d8a9e347"
7SRC_URI[sha256sum] = "a673984a8dd78e4a8b8cfdee5359a1309d833cf38405008f4a249994a8456719"
8
9inherit pypi
10
11DEPENDS += "${PYTHON_PN}-pytest-runner-native"
12
13RDEPENDS_${PN} += "${PYTHON_PN}-astroid \
14 ${PYTHON_PN}-isort \
15 ${PYTHON_PN}-numbers \
16 ${PYTHON_PN}-shell \
17 ${PYTHON_PN}-json \
18 ${PYTHON_PN}-pkgutil \
19 ${PYTHON_PN}-difflib \
20 ${PYTHON_PN}-netserver \
21 "
22
23do_install_append(){
24 rm ${D}${bindir}/pylint
25 cat >> ${D}${bindir}/pylint <<EOF
26#!/usr/bin/env ${PYTHON_PN}
27from pylint import run_pylint
28run_pylint()
29EOF
30 chmod 755 ${D}${bindir}/pylint
31}
diff --git a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb
index f5b4ad052..47ab36a3b 100644
--- a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb
+++ b/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb
@@ -1,44 +1,4 @@
1SUMMARY="Pylint is a Python source code analyzer" 1inherit setuptools
2HOMEPAGE= "http://www.pylint.org/" 2require python-pylint.inc
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
5 3
6SRC_URI[md5sum] = "31da2185bf59142479e4fa16d8a9e347" 4RDEPENDS_${PN} += "${PYTHON_PN}-backports-functools-lru-cache"
7SRC_URI[sha256sum] = "a673984a8dd78e4a8b8cfdee5359a1309d833cf38405008f4a249994a8456719"
8
9RDEPENDS_${PN} += "python-codecs \
10 python-contextlib \
11 python-core \
12 python-distutils \
13 python-io \
14 python-lang \
15 python-multiprocessing \
16 python-netserver \
17 python-numbers \
18 python-pickle \
19 python-re \
20 python-shell \
21 python-six \
22 python-stringold \
23 python-subprocess \
24 python-textutils \
25 python-unittest \
26 python-backports-functools-lru-cache \
27 python-setuptools \
28 python-astroid \
29 python-wrapt \
30 python-isort \
31 python-lazy-object-proxy \
32 "
33
34inherit pypi setuptools
35
36do_install_append(){
37 rm ${D}${bindir}/pylint
38 cat >> ${D}${bindir}/pylint <<EOF
39#!/usr/bin/env python
40from pylint import run_pylint
41run_pylint()
42EOF
43 chmod 755 ${D}${bindir}/pylint
44}
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb
new file mode 100644
index 000000000..fed65b303
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-pylint.inc