diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-08-08 14:47:58 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-13 13:21:02 +0200 |
commit | 2d07918e9cc6e03f8f864605c84290b66b81e998 (patch) | |
tree | 5febba040f5c964b24e1ff2cb70d59c7c245cf37 /meta-python/recipes-devtools/python | |
parent | c1966a1b3f728aa1d6d861a2791ae0cc10ebb14a (diff) | |
download | meta-openembedded-2d07918e9cc6e03f8f864605c84290b66b81e998.tar.gz |
python-grpcio: Do not hardcode compiler -std options
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | 36 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb | 2 |
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch new file mode 100644 index 000000000..3686144b3 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From b02be74a2eff8abc612ef84f30e0fbce6a7f65f5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 4 Aug 2017 09:04:07 -0700 | ||
4 | Subject: [PATCH] setup.py: Do not mix C and C++ compiler options | ||
5 | |||
6 | EXTRA_ENV_COMPILE_ARGS is used both with CC and CXX | ||
7 | so using -std=c++11 or -std=gnu99 together will cause | ||
8 | build time errors espcially with clang | ||
9 | |||
10 | error: invalid argument '-std=gnu99' not allowed with 'C++' | ||
11 | |||
12 | gcc7 ( defaults are -std=gnu11 and -std=gnu++14 ) | ||
13 | as well clang default to these standards mode or newer | ||
14 | anyway | ||
15 | |||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | setup.py | 2 +- | ||
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
20 | |||
21 | diff --git a/setup.py b/setup.py | ||
22 | index cb85273..f79878d 100644 | ||
23 | --- a/setup.py | ||
24 | +++ b/setup.py | ||
25 | @@ -116,7 +116,7 @@ if EXTRA_ENV_COMPILE_ARGS is None: | ||
26 | elif 'win32' in sys.platform: | ||
27 | EXTRA_ENV_COMPILE_ARGS += ' -D_PYTHON_MSVC' | ||
28 | elif "linux" in sys.platform: | ||
29 | - EXTRA_ENV_COMPILE_ARGS += ' -std=c++11 -std=gnu99 -fvisibility=hidden -fno-wrapv' | ||
30 | + EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv' | ||
31 | elif "darwin" in sys.platform: | ||
32 | EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv' | ||
33 | |||
34 | -- | ||
35 | 2.13.4 | ||
36 | |||
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb b/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb index 5412e0243..2446411a1 100644 --- a/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb +++ b/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb | |||
@@ -4,6 +4,8 @@ SECTION = "devel/python" | |||
4 | 4 | ||
5 | DEPENDS = "python-protobuf" | 5 | DEPENDS = "python-protobuf" |
6 | 6 | ||
7 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \ | ||
8 | " | ||
7 | RDEPENDS_${PN} = "python-enum34 \ | 9 | RDEPENDS_${PN} = "python-enum34 \ |
8 | python-futures \ | 10 | python-futures \ |
9 | python-protobuf \ | 11 | python-protobuf \ |