diff options
author | Dominic Sacré <dominic.sacre@gmx.de> | 2015-08-24 17:27:55 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-08-31 19:17:07 +0200 |
commit | 4058807b84c52438b6dbda967875ab1a74b35655 (patch) | |
tree | 021863da5de54a883335a92917d2214baea67c51 /meta-python/recipes-devtools/python | |
parent | 29aa76af6579f95340488d2b5ba6fb66f8ea2771 (diff) | |
download | meta-openembedded-4058807b84c52438b6dbda967875ab1a74b35655.tar.gz |
python3-decorator: Add new recipe
Use a common .inc file for the python-decorator and python3-decorator
recipes.
Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 23 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python-decorator.inc b/meta-python/recipes-devtools/python/python-decorator.inc new file mode 100644 index 000000000..2c230ff26 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-decorator.inc | |||
@@ -0,0 +1,20 @@ | |||
1 | SUMMARY = "Python decorator utilities" | ||
2 | HOMEPAGE = "http://pypi.python.org/pypi/decorator/" | ||
3 | DESCRIPTION = "\ | ||
4 | The aim of the decorator module it to simplify the usage of decorators \ | ||
5 | for the average programmer, and to popularize decorators by showing \ | ||
6 | various non-trivial examples. Of course, as all techniques, decorators \ | ||
7 | can be abused and you should not try to solve every problem with a \ | ||
8 | decorator, just because you can." | ||
9 | |||
10 | SECTION = "devel/python" | ||
11 | LICENSE = "BSD" | ||
12 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=41e24e0e235a97e60cdb5c4137fa2cd0" | ||
13 | |||
14 | SRCNAME = "decorator" | ||
15 | |||
16 | SRC_URI = "https://pypi.python.org/packages/source/d/decorator/decorator-${PV}.tar.gz" | ||
17 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
18 | |||
19 | SRC_URI[md5sum] = "033c9563af492c4ce2680ee6ca481fa7" | ||
20 | SRC_URI[sha256sum] = "1a089279d5de2471c47624d4463f2e5b3fc6a2cf65045c39bf714fc461a25206" | ||
diff --git a/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb b/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb index bda0d713d..f26216846 100644 --- a/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb +++ b/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb | |||
@@ -1,22 +1,2 @@ | |||
1 | SUMMARY = "Python decorator utilities" | ||
2 | HOMEPAGE = "http://pypi.python.org/pypi/decorator/" | ||
3 | DESCRIPTION = "\ | ||
4 | The aim of the decorator module it to simplify the usage of decorators \ | ||
5 | for the average programmer, and to popularize decorators by showing \ | ||
6 | various non-trivial examples. Of course, as all techniques, decorators \ | ||
7 | can be abused and you should not try to solve every problem with a \ | ||
8 | decorator, just because you can." | ||
9 | |||
10 | SECTION = "devel/python" | ||
11 | LICENSE = "BSD" | ||
12 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=41e24e0e235a97e60cdb5c4137fa2cd0" | ||
13 | |||
14 | SRCNAME = "decorator" | ||
15 | |||
16 | SRC_URI = "https://pypi.python.org/packages/source/d/decorator/decorator-${PV}.tar.gz" | ||
17 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
18 | |||
19 | inherit setuptools | 1 | inherit setuptools |
20 | 2 | require python-decorator.inc | |
21 | SRC_URI[md5sum] = "033c9563af492c4ce2680ee6ca481fa7" | ||
22 | SRC_URI[sha256sum] = "1a089279d5de2471c47624d4463f2e5b3fc6a2cf65045c39bf714fc461a25206" | ||
diff --git a/meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb b/meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb new file mode 100644 index 000000000..844cbdc9a --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-decorator.inc | ||