diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2020-01-20 20:17:50 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-22 09:56:34 -0800 |
commit | e6ced573087a6416ec50dce4cf281758be9a2d4c (patch) | |
tree | ea0b161d5de77d03572e76e6e6b9e3482cad8d61 /meta-python/recipes-devtools/python | |
parent | 1ae31787167240729a78a442a378ef354583c012 (diff) | |
download | meta-openembedded-e6ced573087a6416ec50dce4cf281758be9a2d4c.tar.gz |
meta-python: update recipes to use python3 classes
Update recipes to use python3 classes instead of deprecated python2
variants.
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/pamela_0.3.0.bb b/meta-python/recipes-devtools/python/pamela_0.3.0.bb index 030c22f8f..b6bee0ca2 100644 --- a/meta-python/recipes-devtools/python/pamela_0.3.0.bb +++ b/meta-python/recipes-devtools/python/pamela_0.3.0.bb | |||
@@ -7,7 +7,7 @@ SRC_URI[sha256sum] = "1e198446a6cdd87704aa0def7621d62e7c20b0e6068e2788b9a866a835 | |||
7 | 7 | ||
8 | PYPI_PACKAGE = "pamela" | 8 | PYPI_PACKAGE = "pamela" |
9 | 9 | ||
10 | inherit pypi setuptools | 10 | inherit pypi setuptools3 |
11 | 11 | ||
12 | RDEPENDS_${PN} = "libpam" | 12 | RDEPENDS_${PN} = "libpam" |
13 | 13 | ||
diff --git a/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb b/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb index 9d851abe3..798daeb21 100644 --- a/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb +++ b/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb | |||
@@ -8,7 +8,7 @@ PYPI_PACKAGE_EXT = "tar.bz2" | |||
8 | SRC_URI[md5sum] = "7c87da94656b620dfe532ca63d642eb8" | 8 | SRC_URI[md5sum] = "7c87da94656b620dfe532ca63d642eb8" |
9 | SRC_URI[sha256sum] = "b2d701b25ad3f9a1542057f3eb492c5c1d7dbe2b8d1e8f763043dcc14ee1d933" | 9 | SRC_URI[sha256sum] = "b2d701b25ad3f9a1542057f3eb492c5c1d7dbe2b8d1e8f763043dcc14ee1d933" |
10 | 10 | ||
11 | inherit pypi setuptools | 11 | inherit pypi setuptools3 |
12 | 12 | ||
13 | PACKAGES =+ "${PN}-tests ${PN}-samples" | 13 | PACKAGES =+ "${PN}-tests ${PN}-samples" |
14 | 14 | ||
diff --git a/meta-python/recipes-devtools/python/python-yappi.inc b/meta-python/recipes-devtools/python/python-yappi.inc index 54d408742..b3718d7d1 100644 --- a/meta-python/recipes-devtools/python/python-yappi.inc +++ b/meta-python/recipes-devtools/python/python-yappi.inc | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;md5=9a193c13f346884e597acdcac7fe9ac8" | |||
7 | SRC_URI[md5sum] = "a545101aa8a435b0780f06f4723f58c8" | 7 | SRC_URI[md5sum] = "a545101aa8a435b0780f06f4723f58c8" |
8 | SRC_URI[sha256sum] = "7f814131515d51db62b1a3468bcb84de30499124752806a5a6e11caf0b4344bf" | 8 | SRC_URI[sha256sum] = "7f814131515d51db62b1a3468bcb84de30499124752806a5a6e11caf0b4344bf" |
9 | 9 | ||
10 | inherit pypi setuptools | 10 | inherit pypi setuptools3 |
11 | 11 | ||
12 | RDEPENDS_${PN} += "\ | 12 | RDEPENDS_${PN} += "\ |
13 | ${PYTHON_PN}-datetime \ | 13 | ${PYTHON_PN}-datetime \ |
diff --git a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb index 440f69cbf..d82b7b96a 100644 --- a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb +++ b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb | |||
@@ -1,2 +1,2 @@ | |||
1 | inherit pypi setuptools | 1 | inherit pypi setuptools3 |
2 | require python-robotframework-seriallibrary.inc | 2 | require python-robotframework-seriallibrary.inc |