diff options
author | Derek Straka <derek@asterius.io> | 2018-01-03 17:39:32 -0500 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-01-16 21:33:05 -0800 |
commit | d619965394cd2f0785c4aaf1539cb5fc13efce29 (patch) | |
tree | 4eb73048add2da44c041b738228128759e0487a3 /meta-python/recipes-devtools/python | |
parent | e8f3372ecf58fea9106c9a7782afc4006017274d (diff) | |
download | meta-openembedded-d619965394cd2f0785c4aaf1539cb5fc13efce29.tar.gz |
python-jsonpointer: add a python3 version of the recipe
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 18 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpointer.inc b/meta-python/recipes-devtools/python/python-jsonpointer.inc new file mode 100644 index 000000000..e678198cc --- /dev/null +++ b/meta-python/recipes-devtools/python/python-jsonpointer.inc | |||
@@ -0,0 +1,14 @@ | |||
1 | SUMMARY = "Resolve JSON Pointers in Python" | ||
2 | HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer" | ||
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3" | ||
5 | |||
6 | inherit pypi | ||
7 | |||
8 | SRC_URI[md5sum] = "190aeb8afcb0efddfe831a4e533e163b" | ||
9 | SRC_URI[sha256sum] = "c681af823545c731b7b38aedd5d4eee4c5eff87bc0f25e0ff25444a4189eac4d" | ||
10 | |||
11 | RDEPENDS_${PN} += " \ | ||
12 | ${PYTHON_PN}-json \ | ||
13 | ${PYTHON_PN}-re \ | ||
14 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb b/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb index 96b71e3bd..064bd6c5d 100644 --- a/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb +++ b/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb | |||
@@ -1,11 +1,2 @@ | |||
1 | SUMMARY = "Resolve JSON Pointers in Python" | 1 | inherit setuptools |
2 | HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer" | 2 | require python-jsonpointer.inc |
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3" | ||
5 | |||
6 | inherit pypi setuptools | ||
7 | |||
8 | SRC_URI[md5sum] = "190aeb8afcb0efddfe831a4e533e163b" | ||
9 | SRC_URI[sha256sum] = "c681af823545c731b7b38aedd5d4eee4c5eff87bc0f25e0ff25444a4189eac4d" | ||
10 | |||
11 | RDEPENDS_${PN} += "python-re python-json" | ||
diff --git a/meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb b/meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb new file mode 100644 index 000000000..8d0a09b43 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-jsonpointer.inc | ||