diff options
author | Peter Kolbus <peter.kolbus@garmin.com> | 2020-01-02 12:37:43 -0600 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-02 19:29:25 -0800 |
commit | 5b15fb9c839a276220651946efd1d1a303ff0d45 (patch) | |
tree | c4af2918b7ce9b63a89d56dedfe376532470f0fb /meta-python/recipes-devtools/python | |
parent | 8cb441b64045bb2edddf46b5d6b0c0713cbc55a0 (diff) | |
download | meta-openembedded-5b15fb9c839a276220651946efd1d1a303ff0d45.tar.gz |
python3-license-expression: add recipe
python3-license-expression is a utility library to parse and work with
license expressions.
Signed-off-by: Peter Kolbus <peter.kolbus@garmin.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-license-expression.inc | 16 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-license-expression_1.0.bb | 2 |
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-license-expression.inc b/meta-python/recipes-devtools/python/python-license-expression.inc new file mode 100644 index 000000000..4c35e8dd7 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-license-expression.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions" | ||
2 | HOMEPAGE = "https://github.com/nexB/license-expression" | ||
3 | |||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa" | ||
6 | |||
7 | SRC_URI[md5sum] = "81477f779099f55071c6a7b88a29bb01" | ||
8 | SRC_URI[sha256sum] = "8aaa455c5b97c4f2174090178b19792b2a1c620e80591aafd4e0a99b713f9e8d" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | RDEPENDS_${PN} += "\ | ||
13 | ${PYTHON_PN}-booleanpy \ | ||
14 | " | ||
15 | |||
16 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-license-expression_1.0.bb b/meta-python/recipes-devtools/python/python3-license-expression_1.0.bb new file mode 100644 index 000000000..10a702ca4 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-license-expression_1.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-license-expression.inc | ||