diff options
author | Derek Straka <derek@asterius.io> | 2020-02-14 13:57:24 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-15 08:05:07 -0800 |
commit | 48c61dfe2385f6d3af78a8542d5ad30ed6c2f789 (patch) | |
tree | f0771862b2130648aaa1423555264444e4366cd9 /meta-python/recipes-devtools/python | |
parent | 747b6bd61f20bb782ad5c38066893038717c35a7 (diff) | |
download | meta-openembedded-48c61dfe2385f6d3af78a8542d5ad30ed6c2f789.tar.gz |
python3-behave: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-behave.inc | 15 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-behave_1.2.6.bb | 17 |
2 files changed, 15 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-behave.inc b/meta-python/recipes-devtools/python/python-behave.inc deleted file mode 100644 index ded75801d..000000000 --- a/meta-python/recipes-devtools/python/python-behave.inc +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | SUMMARY = "A behavior-driven development framework, Python style" | ||
2 | HOMEPAGE = "https://github.com/behave/behave" | ||
3 | LICENSE = "BSD-2-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06" | ||
5 | |||
6 | SRC_URI[md5sum] = "3f05c859a1c45f5ed33e925817ad887d" | ||
7 | SRC_URI[sha256sum] = "b9662327aa53294c1351b0a9c369093ccec1d21026f050c3bd9b3e5cccf81a86" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | RDEPENDS_${PN} += " \ | ||
12 | ${PYTHON_PN}-parse-type \ | ||
13 | ${PYTHON_PN}-setuptools \ | ||
14 | ${PYTHON_PN}-six \ | ||
15 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb b/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb index 1c55871b1..a28e52731 100644 --- a/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb +++ b/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb | |||
@@ -1,2 +1,15 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "A behavior-driven development framework, Python style" |
2 | require python-behave.inc | 2 | HOMEPAGE = "https://github.com/behave/behave" |
3 | LICENSE = "BSD-2-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06" | ||
5 | |||
6 | SRC_URI[md5sum] = "3f05c859a1c45f5ed33e925817ad887d" | ||
7 | SRC_URI[sha256sum] = "b9662327aa53294c1351b0a9c369093ccec1d21026f050c3bd9b3e5cccf81a86" | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | RDEPENDS_${PN} += " \ | ||
12 | ${PYTHON_PN}-parse-type \ | ||
13 | ${PYTHON_PN}-setuptools \ | ||
14 | ${PYTHON_PN}-six \ | ||
15 | " | ||