summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 17:35:27 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commit1dbe0e298140bd549345f6a21371dea507d36434 (patch)
treea222553ffc205ebcb2d311b717003f7ba98072eb /meta-python/recipes-devtools/python
parente2e028c216825aed94b65467ca950f84832e27ca (diff)
downloadmeta-openembedded-1dbe0e298140bd549345f6a21371dea507d36434.tar.gz
python3-certifi: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-certifi.inc13
-rw-r--r--meta-python/recipes-devtools/python/python3-certifi_2019.11.28.bb15
2 files changed, 14 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-certifi.inc b/meta-python/recipes-devtools/python/python-certifi.inc
deleted file mode 100644
index 98fa1f288..000000000
--- a/meta-python/recipes-devtools/python/python-certifi.inc
+++ /dev/null
@@ -1,13 +0,0 @@
1SUMMARY = "Python package for providing Mozilla's CA Bundle."
2DESCRIPTION = "This installable Python package contains a CA Bundle that you can reference in your \
3Python code. This is useful for verifying HTTP requests, for example. This is the same CA Bundle \
4which ships with the Requests codebase, and is derived from Mozilla Firefox's canonical set."
5HOMEPAGE = " http://certifi.io/"
6
7LICENSE = "ISC"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=f77f61d14ee6feac4228d3ebd26cc1f1"
9
10SRC_URI[md5sum] = "4d5229c4d9f0a4a79106f9e2c2cfd381"
11SRC_URI[sha256sum] = "25b64c7da4cd7479594d035c08c2d809eb4aab3a26e5a990ea98cc450c320f1f"
12
13BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-certifi_2019.11.28.bb b/meta-python/recipes-devtools/python/python3-certifi_2019.11.28.bb
index 70f674b22..c9e945f27 100644
--- a/meta-python/recipes-devtools/python/python3-certifi_2019.11.28.bb
+++ b/meta-python/recipes-devtools/python/python3-certifi_2019.11.28.bb
@@ -1,2 +1,15 @@
1SUMMARY = "Python package for providing Mozilla's CA Bundle."
2DESCRIPTION = "This installable Python package contains a CA Bundle that you can reference in your \
3Python code. This is useful for verifying HTTP requests, for example. This is the same CA Bundle \
4which ships with the Requests codebase, and is derived from Mozilla Firefox's canonical set."
5HOMEPAGE = " http://certifi.io/"
6
7LICENSE = "ISC"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=f77f61d14ee6feac4228d3ebd26cc1f1"
9
10SRC_URI[md5sum] = "4d5229c4d9f0a4a79106f9e2c2cfd381"
11SRC_URI[sha256sum] = "25b64c7da4cd7479594d035c08c2d809eb4aab3a26e5a990ea98cc450c320f1f"
12
1inherit pypi setuptools3 13inherit pypi setuptools3
2require python-certifi.inc 14
15BBCLASSEXTEND = "native nativesdk"