summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorKrzysztof Kozlowski <krzk@kernel.org>2017-07-09 17:47:21 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:31 +0200
commitd0513b1d6137168a69f93c0eb84fbe77ccfd0145 (patch)
treefac41cf7369b81e0833111f6a491e27e70738285 /meta-python/recipes-devtools/python
parentc15782ebe5bf342d3328572c28d00788df9ea095 (diff)
downloadmeta-openembedded-d0513b1d6137168a69f93c0eb84fbe77ccfd0145.tar.gz
meta-python: Add Protobuf and gRPC Python recipes
Add recipes for Python PIP packages for Google's Protobuf, gRPC and gRPC tools. Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio-tools_1.4.0.bb17
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb23
-rw-r--r--meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb16
3 files changed, 56 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio-tools_1.4.0.bb b/meta-python/recipes-devtools/python/python-grpcio-tools_1.4.0.bb
new file mode 100644
index 000000000..f9cfd9967
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio-tools_1.4.0.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5DEPENDS = "python-grpcio"
6RDEPENDS_${PN} = "python-grpcio"
7
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
10
11inherit pypi setuptools
12
13SRC_URI[md5sum] = "b0d585872c69f207a05c55566e8afb38"
14SRC_URI[sha256sum] = "bddc98f063755a5df9d285666db49c49201f93d416c45d4f4924cf752b68c99c"
15
16# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
17BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb b/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb
new file mode 100644
index 000000000..5412e0243
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5DEPENDS = "python-protobuf"
6
7RDEPENDS_${PN} = "python-enum34 \
8 python-futures \
9 python-protobuf \
10 python-setuptools \
11 python-six \
12"
13
14LICENSE = "BSD-3-Clause"
15LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
16
17inherit pypi setuptools
18
19SRC_URI[md5sum] = "d882ae4eeef4f32ac9c1d32052bf05ad"
20SRC_URI[sha256sum] = "a3a213a4c24b5c572b386d752e3b74a3f1b8fa5d03c07b6166fa39f3a6cdef34"
21
22# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
23BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb b/meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb
new file mode 100644
index 000000000..61b8fef00
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-protobuf_3.3.0.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Protocol Buffers"
2HOMEPAGE = "https://developers.google.com/protocol-buffers/"
3SECTION = "devel/python"
4
5RDEPENDS_${PN} = "python-six"
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
9
10inherit pypi setuptools
11
12SRC_URI[md5sum] = "27941e8e42e83d5183605054576882dd"
13SRC_URI[sha256sum] = "1cbcee2c45773f57cb6de7ee0eceb97f92b9b69c0178305509b162c0160c1f04"
14
15# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
16BBCLASSEXTEND = "native"