summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDaniela Plascencia <daniela.plascencia@linux.intel.com>2017-06-20 12:20:03 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-22 16:03:00 +0200
commitb184b6dbf5962494b15fe151a01a0be27b28ef63 (patch)
tree495dcdd0de63c3b896e6701cc6b386564c4452be /meta-python/recipes-devtools/python
parent6e36914607f5174128c5161667c9e51ff1f451a8 (diff)
downloadmeta-openembedded-b184b6dbf5962494b15fe151a01a0be27b28ef63.tar.gz
python-isort: adds Python3 support
Extend the recipe for Python3 support. Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-isort.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-isort_4.2.15.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-isort_4.2.15.bb2
3 files changed, 14 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-isort.inc b/meta-python/recipes-devtools/python/python-isort.inc
new file mode 100644
index 000000000..9884c44f1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-isort.inc
@@ -0,0 +1,10 @@
1SUMMARY = "A Python utility / library to sort Python imports."
2HOMEPAGE = "https://pypi.python.org/pypi/isort"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
6
7SRC_URI[md5sum] = "34915a2ce60e6fe3dbcbf5982deef9b4"
8SRC_URI[sha256sum] = "79f46172d3a4e2e53e7016e663cc7a8b538bec525c36675fcfd2767df30b3983"
9
10inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-isort_4.2.15.bb b/meta-python/recipes-devtools/python/python-isort_4.2.15.bb
index b310fda02..fa46d89b5 100644
--- a/meta-python/recipes-devtools/python/python-isort_4.2.15.bb
+++ b/meta-python/recipes-devtools/python/python-isort_4.2.15.bb
@@ -1,11 +1,2 @@
1SUMMARY = "A Python utility / library to sort Python imports." 1inherit setuptools
2HOMEPAGE = "https://pypi.python.org/pypi/isort" 2require python-isort.inc
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
6
7SRC_URI[md5sum] = "34915a2ce60e6fe3dbcbf5982deef9b4"
8SRC_URI[sha256sum] = "79f46172d3a4e2e53e7016e663cc7a8b538bec525c36675fcfd2767df30b3983"
9
10inherit setuptools pypi
11
diff --git a/meta-python/recipes-devtools/python/python3-isort_4.2.15.bb b/meta-python/recipes-devtools/python/python3-isort_4.2.15.bb
new file mode 100644
index 000000000..755b3e2f2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-isort_4.2.15.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-isort.inc