diff options
author | Pascal Bach <pascal.bach@siemens.com> | 2017-04-06 14:05:21 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-18 14:21:38 +0200 |
commit | 4175dc4a8b6a5c452133dbc149b0b77b5aed13cb (patch) | |
tree | b9ab0e029b4c39b53d8dd25b86665ac81d4ce438 /meta-python/recipes-devtools/python | |
parent | f882211c14507894248bb4ff064153b242d1d9d7 (diff) | |
download | meta-openembedded-4175dc4a8b6a5c452133dbc149b0b77b5aed13cb.tar.gz |
python-paho-mqtt: make recipe available as python3 version
Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 19 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt.inc b/meta-python/recipes-devtools/python/python-paho-mqtt.inc new file mode 100644 index 000000000..7ff3fb242 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-paho-mqtt.inc | |||
@@ -0,0 +1,14 @@ | |||
1 | SUMMARY = "MQTT version 3.1/3.1.1 client library" | ||
2 | LICENSE = "EPL-1.0" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc" | ||
4 | SRCNAME = "paho-mqtt" | ||
5 | |||
6 | inherit pypi | ||
7 | SRC_URI[md5sum] = "241150b3fcb920ddca4d33181f3238b1" | ||
8 | SRC_URI[sha256sum] = "9100a6aa706ab699d414ec02705a21eb66f436184691d0bf1f2a85a6213c6c1f" | ||
9 | |||
10 | RDEPENDS_${PN} = "\ | ||
11 | ${PYTHON_PN}-math \ | ||
12 | ${PYTHON_PN}-io \ | ||
13 | ${PYTHON_PN}-threading \ | ||
14 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb b/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb index c8acfc557..f369b2e84 100644 --- a/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb +++ b/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb | |||
@@ -1,15 +1,3 @@ | |||
1 | SUMMARY = "MQTT version 3.1/3.1.1 client library" | 1 | inherit setuptools |
2 | LICENSE = "EPL-1.0" | 2 | require python-paho-mqtt.inc |
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc" | ||
4 | SRCNAME = "paho-mqtt" | ||
5 | 3 | ||
6 | inherit pypi setuptools | ||
7 | |||
8 | RDEPENDS_${PN} = "\ | ||
9 | python-math \ | ||
10 | python-io \ | ||
11 | python-threading \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "241150b3fcb920ddca4d33181f3238b1" | ||
15 | SRC_URI[sha256sum] = "9100a6aa706ab699d414ec02705a21eb66f436184691d0bf1f2a85a6213c6c1f" | ||
diff --git a/meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb new file mode 100644 index 000000000..4981e61ed --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb | |||
@@ -0,0 +1,3 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-paho-mqtt.inc | ||
3 | |||