diff options
author | Derek Straka <derek@asterius.io> | 2017-12-25 13:25:13 -0500 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-12-30 12:33:18 -0800 |
commit | 83b097cc3b9ed4a45cb8b1fb3b3ef8a09f32ea48 (patch) | |
tree | 9c10a719f1127394059c1be9d05bae61319459e8 /meta-python/recipes-devtools/python | |
parent | 91a32418bd771fe914c531a6a96303355b108e87 (diff) | |
download | meta-openembedded-83b097cc3b9ed4a45cb8b1fb3b3ef8a09f32ea48.tar.gz |
python-flask-wtf: update to version 0.14.2
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-flask-wtf.inc | 13 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch | 28 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-flask-wtf_0.14.2.bb (renamed from meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb) | 0 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-flask-wtf_0.14.2.bb (renamed from meta-python/recipes-devtools/python/python3-flask-wtf_0.12.bb) | 0 |
4 files changed, 6 insertions, 35 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf.inc b/meta-python/recipes-devtools/python/python-flask-wtf.inc index 3a959aed7..3c90656ad 100644 --- a/meta-python/recipes-devtools/python/python-flask-wtf.inc +++ b/meta-python/recipes-devtools/python/python-flask-wtf.inc | |||
@@ -1,16 +1,15 @@ | |||
1 | DESCRIPTION = "Simple integration of Flask and WTForms." | 1 | DESCRIPTION = "Simple integration of Flask and WTForms." |
2 | LICENSE = "BSD" | 2 | LICENSE = "BSD" |
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=507e8635f25a06dc4f041a3a1b3359b3" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3ca6bb31670492f791e6a9f2fb9f8a80" |
4 | 4 | ||
5 | SRC_URI[md5sum] = "c53a74e8ba481bf53405fd5efdf0339e" | 5 | SRC_URI[md5sum] = "586f50f233926cade42e3d744aca3e8f" |
6 | SRC_URI[sha256sum] = "bd99316c97ed1d1cb90b8f0c242c86420a891a6a2058f20717e424bf5b0bb80e" | 6 | SRC_URI[sha256sum] = "5d14d55cfd35f613d99ee7cba0fc3fbbe63ba02f544d349158c14ca15561cc36" |
7 | |||
8 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-flask-wtf:" | ||
9 | SRC_URI += " file://import-simplejson-as-json.patch" | ||
10 | 7 | ||
11 | PYPI_PACKAGE = "Flask-WTF" | 8 | PYPI_PACKAGE = "Flask-WTF" |
12 | 9 | ||
13 | RDEPENDS_${PN} = "\ | 10 | RDEPENDS_${PN} = "\ |
11 | ${PYTHON_PN}-flask \ | ||
12 | ${PYTHON_PN}-itsdangerous \ | ||
13 | ${PYTHON_PN}-json \ | ||
14 | ${PYTHON_PN}-wtforms \ | 14 | ${PYTHON_PN}-wtforms \ |
15 | ${PYTHON_PN}-simplejson \ | ||
16 | " | 15 | " |
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch b/meta-python/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch deleted file mode 100644 index 678f7062b..000000000 --- a/meta-python/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | Upstream-Status: Inappropriate [configuration] | ||
2 | |||
3 | Subject: [PATCH] import simplejson as json | ||
4 | |||
5 | At runtime python-Flask-WTF tries to import json, but the module is not | ||
6 | available, import simplejson as json solve the issue. | ||
7 | |||
8 | Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> | ||
9 | --- | ||
10 | flask_wtf/recaptcha/validators.py | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/flask_wtf/recaptcha/validators.py b/flask_wtf/recaptcha/validators.py | ||
14 | index bcff23d..4a244bb 100644 | ||
15 | --- a/flask_wtf/recaptcha/validators.py | ||
16 | +++ b/flask_wtf/recaptcha/validators.py | ||
17 | @@ -8,7 +8,7 @@ from flask import request, current_app | ||
18 | from wtforms import ValidationError | ||
19 | from werkzeug import url_encode | ||
20 | from .._compat import to_bytes, to_unicode | ||
21 | -import json | ||
22 | +import simplejson as json | ||
23 | |||
24 | RECAPTCHA_VERIFY_SERVER = 'https://www.google.com/recaptcha/api/siteverify' | ||
25 | RECAPTCHA_ERROR_CODES = { | ||
26 | -- | ||
27 | 2.1.4 | ||
28 | |||
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb b/meta-python/recipes-devtools/python/python-flask-wtf_0.14.2.bb index dbf091bc0..dbf091bc0 100644 --- a/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb +++ b/meta-python/recipes-devtools/python/python-flask-wtf_0.14.2.bb | |||
diff --git a/meta-python/recipes-devtools/python/python3-flask-wtf_0.12.bb b/meta-python/recipes-devtools/python/python3-flask-wtf_0.14.2.bb index 52362a865..52362a865 100644 --- a/meta-python/recipes-devtools/python/python3-flask-wtf_0.12.bb +++ b/meta-python/recipes-devtools/python/python3-flask-wtf_0.14.2.bb | |||