diff options
author | Ross Burton <ross@burtonini.com> | 2021-11-18 16:11:33 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-11-19 08:30:36 -0800 |
commit | 2d63ec9476690a0da648c805dc3fdb9b0201bbbb (patch) | |
tree | 256ef036c93d4c169fd77c247e8e6049c4bb9302 /meta-python/recipes-devtools/python | |
parent | cf172e66fe8f0ba6f676beb1eae6efb7c00d8b1a (diff) | |
download | meta-openembedded-2d63ec9476690a0da648c805dc3fdb9b0201bbbb.tar.gz |
python3-gevent: use system libraries instead of embedding
gevent by default will build its own c-ares and libuv, but that build
needs patches and embedded libraries are bad form.
DEPEND on the recipes instead, and turn off embedding.
Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-gevent/libev-conf.patch | 26 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb | 22 |
2 files changed, 8 insertions, 40 deletions
diff --git a/meta-python/recipes-devtools/python/python-gevent/libev-conf.patch b/meta-python/recipes-devtools/python/python-gevent/libev-conf.patch deleted file mode 100644 index 79c1867ba..000000000 --- a/meta-python/recipes-devtools/python/python-gevent/libev-conf.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 2294734ef9d5e2efb05820e9759a1635799bdea9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrej Rode <andrej.rode@ettus.com> | ||
3 | Date: Mon, 10 Apr 2017 19:25:18 -0700 | ||
4 | Subject: [PATCH] libev: make configure crosscompile compatible | ||
5 | |||
6 | Signed-off-by: Andrej Rode <andrej.rode@ettus.com> | ||
7 | --- | ||
8 | deps/libev/configure | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/deps/libev/configure b/deps/libev/configure | ||
12 | index 743817e..96c2366 100755 | ||
13 | --- a/deps/libev/configure | ||
14 | +++ b/deps/libev/configure | ||
15 | @@ -2208,7 +2208,7 @@ fi | ||
16 | ac_ext=c | ||
17 | ac_cpp='$CPP $CPPFLAGS' | ||
18 | ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5' | ||
19 | -ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5' | ||
20 | +ac_link='$CC -static -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5' | ||
21 | ac_compiler_gnu=$ac_cv_c_compiler_gnu | ||
22 | |||
23 | |||
24 | -- | ||
25 | 2.10.2 | ||
26 | |||
diff --git a/meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb b/meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb index 74ae6cf69..8fb6e1850 100644 --- a/meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb +++ b/meta-python/recipes-devtools/python/python3-gevent_21.8.0.bb | |||
@@ -7,27 +7,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \ | |||
7 | file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \ | 7 | file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \ |
8 | file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \ | 8 | file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \ |
9 | " | 9 | " |
10 | DEPENDS += "libevent" | 10 | DEPENDS += "${PYTHON_PN}-greenlet libev c-ares" |
11 | DEPENDS += "${PYTHON_PN}-greenlet" | 11 | |
12 | RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \ | 12 | RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \ |
13 | ${PYTHON_PN}-mime \ | 13 | ${PYTHON_PN}-mime \ |
14 | ${PYTHON_PN}-pprint \ | 14 | ${PYTHON_PN}-pprint \ |
15 | " | 15 | " |
16 | 16 | ||
17 | FILESEXTRAPATHS:prepend := "${THISDIR}/python-gevent:" | 17 | SRC_URI[sha256sum] = "43e93e1a4738c922a2416baf33f0afb0a20b22d3dba886720bc037cd02a98575" |
18 | 18 | ||
19 | SRC_URI:append = " \ | 19 | inherit pypi setuptools3 |
20 | file://libev-conf.patch;patch=1;pnum=1 \ | ||
21 | " | ||
22 | 20 | ||
23 | SRC_URI[sha256sum] = "43e93e1a4738c922a2416baf33f0afb0a20b22d3dba886720bc037cd02a98575" | 21 | # Don't embed libraries, link to the system instead |
22 | export GEVENTSETUP_EMBED = "0" | ||
24 | 23 | ||
25 | # The python-gevent has no autoreconf ability | 24 | # Delete the embedded copies of libraries so we can't accidentally link to them |
26 | # and the logic for detecting a cross compile is flawed | ||
27 | # so always force a cross compile | ||
28 | do_configure:append() { | 25 | do_configure:append() { |
29 | sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/libev/configure | 26 | rm -rf ${S}/deps |
30 | sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/c-ares/configure | ||
31 | } | 27 | } |
32 | |||
33 | inherit pypi setuptools3 | ||