diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-06-13 09:40:12 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-06-14 09:41:35 -0700 |
commit | 0347cd1b9712012da5d408b3dce123ce6adeda5c (patch) | |
tree | 62d1178acb5f03427a47a423150c12f9c8d56ee6 /meta-python/recipes-devtools/python | |
parent | 49ae33aba52ebb76251db4cac713633836d0914a (diff) | |
download | meta-openembedded-0347cd1b9712012da5d408b3dce123ce6adeda5c.tar.gz |
python3-django: upgrade 4.2.1 -> 4.2.2
Changelog:
==========
- Fixed a regression in Django 4.2 that caused an unnecessary DBMS_LOB.SUBSTR()
wrapping in the __isnull and __exact=None lookups for TextField()/BinaryField()
on Oracle (#34544).
- Restored, following a regression in Django 4.2, get_prep_value() call in
JSONField subclasses (#34539).
- Fixed a regression in Django 4.2 that caused a crash of QuerySet.defer() when
passing a ManyToManyField or GenericForeignKey reference. While doing so is a
no-op, it was allowed in older version (#34570).
- Fixed a regression in Django 4.2 that caused a crash of QuerySet.only() when
passing a reverse OneToOneField reference (#34612).
- Fixed a bug in Django 4.2 where makemigrations --update didn't respect the
--name option (#34568).
- Fixed a performance regression in Django 4.2 when compiling queries without
ordering (#34580).
- Fixed a regression in Django 4.2 where nonexistent stylesheet was linked on a
"Congratulations!" page (#34588).
- Fixed a regression in Django 4.2 that caused a crash of QuerySet.aggregate()
with expressions referencing other aggregates (#34551).
- Fixed a regression in Django 4.2 that caused a crash of QuerySet.aggregate()
with aggregates referencing subqueries (#34551).
- Fixed a regression in Django 4.2 that caused a crash of querysets on SQLite
when filtering on DecimalField against values outside of the defined range (#34590).
- Fixed a regression in Django 4.2 that caused a serialization crash on a
ManyToManyField without a natural key when its Manager's base QuerySet used select_related() (#34620).
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-django_4.2.2.bb (renamed from meta-python/recipes-devtools/python/python3-django_4.2.1.bb) | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-django_4.2.1.bb b/meta-python/recipes-devtools/python/python3-django_4.2.2.bb index b1474cf05..da65eb9c3 100644 --- a/meta-python/recipes-devtools/python/python3-django_4.2.1.bb +++ b/meta-python/recipes-devtools/python/python3-django_4.2.2.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | require python-django.inc | 1 | require python-django.inc |
2 | inherit setuptools3 | 2 | inherit setuptools3 |
3 | 3 | ||
4 | SRC_URI[sha256sum] = "7efa6b1f781a6119a10ac94b4794ded90db8accbe7802281cd26f8664ffed59c" | 4 | SRC_URI[sha256sum] = "2a6b6fbff5b59dd07bef10bcb019bee2ea97a30b2a656d51346596724324badf" |
5 | 5 | ||
6 | RDEPENDS:${PN} += "\ | 6 | RDEPENDS:${PN} += "\ |
7 | ${PYTHON_PN}-sqlparse \ | 7 | ${PYTHON_PN}-sqlparse \ |