summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-11-23 12:13:47 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:33:06 +0100
commit06f04adf4b6572f79839240bdd6e0b0f389bbc08 (patch)
treee03e40b6d324090e3313c6e224f2b3c54c08602b /meta-python/recipes-devtools/python
parent2463e39c449cb3431e28a2a1ed5c31f778bf47bc (diff)
downloadmeta-openembedded-06f04adf4b6572f79839240bdd6e0b0f389bbc08.tar.gz
python-cryptography, python-cryptography-vectors: uprev
Pick up many fixes and enhancements made since 0.8.1 was released. See: https://github.com/pyca/cryptography/blob/master/CHANGELOG.rst The uprev requires an uprev of pyasn1 and also pulls in two new packages idna and ipaddress. The idna software has 3 licenses, one of which is the 'Unicode' license: http://www.unicode.org/copyright.html Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography-vectors_1.1.bb (renamed from meta-python/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb)4
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_1.1.bb (renamed from meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb)11
-rw-r--r--meta-python/recipes-devtools/python/python-idna_git.bb22
-rw-r--r--meta-python/recipes-devtools/python/python-ipaddress_git.bb22
-rw-r--r--meta-python/recipes-devtools/python/python-pyasn1_0.1.9.bb (renamed from meta-python/recipes-devtools/python/python-pyasn1_0.1.7.bb)8
5 files changed, 59 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb b/meta-python/recipes-devtools/python/python-cryptography-vectors_1.1.bb
index a9b64ed13..2150e5078 100644
--- a/meta-python/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb
+++ b/meta-python/recipes-devtools/python/python-cryptography-vectors_1.1.bb
@@ -8,7 +8,7 @@ SRCNAME = "cryptography_vectors"
8SRC_URI = "https://pypi.python.org/packages/source/c/cryptography-vectors/${SRCNAME}-${PV}.tar.gz" 8SRC_URI = "https://pypi.python.org/packages/source/c/cryptography-vectors/${SRCNAME}-${PV}.tar.gz"
9S = "${WORKDIR}/${SRCNAME}-${PV}" 9S = "${WORKDIR}/${SRCNAME}-${PV}"
10 10
11SRC_URI[md5sum] = "04fcfcc61aee62e3b4beb1740cd120ac" 11SRC_URI[md5sum] = "0ad422501074929c06b7edd40df41844"
12SRC_URI[sha256sum] = "4a69e66026bfce4b97f75e72fe262f5e8f71daddc081f6608e5b0db89e552504" 12SRC_URI[sha256sum] = "a929fbb0eac391c93c5745451a4d4157a8bc18eb2e69faf3af1d825ceacbf32c"
13 13
14inherit setuptools 14inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb b/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
index 41e4acdb5..b3eee0309 100644
--- a/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb
+++ b/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
@@ -10,8 +10,8 @@ SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}
10" 10"
11S = "${WORKDIR}/${SRCNAME}-${PV}" 11S = "${WORKDIR}/${SRCNAME}-${PV}"
12 12
13SRC_URI[md5sum] = "70dde78a5515abdbfd7a3d58f15689ab" 13SRC_URI[md5sum] = "dd06da41535184f48f2c8e8b74dd570f"
14SRC_URI[sha256sum] = "f4e041bc83c1be94d87116a7aa201c378b7c6581be4d83994b2da0a84499f73b" 14SRC_URI[sha256sum] = "059bc6428b1d0e2317f505698602642f1d8dda5b120ec573a59a430d8cb7a32d"
15 15
16inherit pypi 16inherit pypi
17 17
@@ -26,6 +26,9 @@ RDEPENDS_${PN} = "\
26 python-threading\ 26 python-threading\
27 python-numbers\ 27 python-numbers\
28 python-contextlib\ 28 python-contextlib\
29 python-ipaddress\
30 python-pyasn1\
31 python-idna\
29" 32"
30 33
31RDEPENDS_${PN}-ptest = "\ 34RDEPENDS_${PN}-ptest = "\
@@ -44,3 +47,7 @@ do_install_ptest() {
44 install -d ${D}${PTEST_PATH}/tests/hazmat 47 install -d ${D}${PTEST_PATH}/tests/hazmat
45 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/ 48 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
46} 49}
50
51FILES_${PN}-dbg += " \
52 ${libdir}/python2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
53 " \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python-idna_git.bb b/meta-python/recipes-devtools/python/python-idna_git.bb
new file mode 100644
index 000000000..f5ce658cb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-idna_git.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Internationalised Domain Names in Applications"
2HOMEPAGE = "https://github.com/kjd/idna"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause & Python-2.0 & Unicode"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c61e6ec7ab3da6b340d8d3a89c964ef2"
6
7PV = "2.0"
8SRCREV = "bb6e94c5b5525684d8ca010bf8ab42480c319e0a"
9
10SRCNAME = "idna"
11SRC_URI = "git://github.com/kjd/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pip \
19 "
20
21RDEPENDS_${PN} += " \
22 "
diff --git a/meta-python/recipes-devtools/python/python-ipaddress_git.bb b/meta-python/recipes-devtools/python/python-ipaddress_git.bb
new file mode 100644
index 000000000..3d138338e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-ipaddress_git.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Python 3.3+'s ipaddress for Python 2.6, 2.7, 3.2."
2HOMEPAGE = "https://github.com/phihag/ipaddress"
3SECTION = "devel/python"
4LICENSE = "Python-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7f538584cc3407bf76042def7168548a"
6
7PV = "1.0.15"
8SRCREV = "95adb9f374a1cca5efda08d20d9fc58d955d4a42"
9
10SRCNAME = "ipaddress"
11SRC_URI = "git://github.com/phihag/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pip \
19 "
20
21RDEPENDS_${PN} += " \
22 "
diff --git a/meta-python/recipes-devtools/python/python-pyasn1_0.1.7.bb b/meta-python/recipes-devtools/python/python-pyasn1_0.1.9.bb
index 0fe690973..202e4dc0c 100644
--- a/meta-python/recipes-devtools/python/python-pyasn1_0.1.7.bb
+++ b/meta-python/recipes-devtools/python/python-pyasn1_0.1.9.bb
@@ -1,13 +1,13 @@
1DESCRIPTION = "Python library implementing ASN.1 types." 1DESCRIPTION = "Python library implementing ASN.1 types."
2HOMEPAGE = "http://pyasn1.sourceforge.net/" 2HOMEPAGE = "http://pyasn1.sourceforge.net/"
3SECTION = "devel/python" 3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause" 4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=ae098273b2cf8b4af164ac20e32bddf7" 5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=425e62320d430219736139b134db2fc4"
6DEPENDS = "python" 6DEPENDS = "python"
7 7
8SRC_URI = "https://pypi.python.org/packages/source/p/pyasn1/pyasn1-${PV}.tar.gz" 8SRC_URI = "https://pypi.python.org/packages/source/p/pyasn1/pyasn1-${PV}.tar.gz"
9SRC_URI[md5sum] = "2cbd80fcd4c7b1c82180d3d76fee18c8" 9SRC_URI[md5sum] = "f00a02a631d4016818659d1cc38d229a"
10SRC_URI[sha256sum] = "e4f81d53c533f6bd9526b047f047f7b101c24ab17339c1a7ad8f98b25c101eab" 10SRC_URI[sha256sum] = "853cacd96d1f701ddd67aa03ecc05f51890135b7262e922710112f12a2ed2a7f"
11 11
12S = "${WORKDIR}/pyasn1-${PV}" 12S = "${WORKDIR}/pyasn1-${PV}"
13 13