diff options
author | Derek Straka <derek@asterius.io> | 2017-09-19 15:38:41 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-09-22 22:50:46 +0000 |
commit | c9715e880b6d5b30ca17778f1d354b7b54ba8960 (patch) | |
tree | df0a3a04c02da21372362c5f41782327d8b27413 /meta-python/recipes-devtools/python | |
parent | baa5f5cdf9639d661749d42b96e5222500f8c9df (diff) | |
download | meta-openembedded-c9715e880b6d5b30ca17778f1d354b7b54ba8960.tar.gz |
python-bitarray: add a python3 version of the recipe
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 15 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-bitarray.inc b/meta-python/recipes-devtools/python/python-bitarray.inc new file mode 100644 index 000000000..7b6e0d1b3 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-bitarray.inc | |||
@@ -0,0 +1,11 @@ | |||
1 | SUMMARY = "A high-level Python efficient arrays of booleans -- C extension" | ||
2 | HOMEPAGE = "https://github.com/ilanschnell/bitarray" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3ba469353f9f2a244b2075902351e37d" | ||
5 | |||
6 | SRC_URI[md5sum] = "3825184f54f4d93508a28031b4c65d3b" | ||
7 | SRC_URI[sha256sum] = "7da501356e48a83c61f479393681c1bc4b94e5a34ace7e08cb29e7dd9290ab18" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | BBCLASSEXTEND = "nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-bitarray_0.8.1.bb b/meta-python/recipes-devtools/python/python-bitarray_0.8.1.bb index 145f1fbef..f78c7abd2 100644 --- a/meta-python/recipes-devtools/python/python-bitarray_0.8.1.bb +++ b/meta-python/recipes-devtools/python/python-bitarray_0.8.1.bb | |||
@@ -1,11 +1,2 @@ | |||
1 | SUMMARY = "A high-level Python efficient arrays of booleans -- C extension" | 1 | inherit setuptools |
2 | HOMEPAGE = "https://github.com/ilanschnell/bitarray" | 2 | require python-bitarray.inc |
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3ba469353f9f2a244b2075902351e37d" | ||
5 | |||
6 | SRC_URI[md5sum] = "3825184f54f4d93508a28031b4c65d3b" | ||
7 | SRC_URI[sha256sum] = "7da501356e48a83c61f479393681c1bc4b94e5a34ace7e08cb29e7dd9290ab18" | ||
8 | |||
9 | inherit pypi setuptools | ||
10 | |||
11 | BBCLASSEXTEND = "nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_0.8.1.bb b/meta-python/recipes-devtools/python/python3-bitarray_0.8.1.bb new file mode 100644 index 000000000..7ee444dc9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-bitarray_0.8.1.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-bitarray.inc | ||