diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-09-02 14:28:06 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-09-05 13:04:28 -0700 |
commit | b6d967f052cc40887849a144e377cc7437e5bef6 (patch) | |
tree | 8e49f4e0b919b8a8780aaba5945949f2a8ab1cfb /meta-python/recipes-devtools/python | |
parent | bcb25c13d044f87fa864931097e194a93b9bf978 (diff) | |
download | meta-openembedded-b6d967f052cc40887849a144e377cc7437e5bef6.tar.gz |
python3-systemd: Consolidate in a single file
Consolidate inc and bb files into a single bb file.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-systemd.inc | 20 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-systemd_234.bb | 23 |
2 files changed, 20 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd.inc b/meta-python/recipes-devtools/python/python-systemd.inc deleted file mode 100644 index b14f82501..000000000 --- a/meta-python/recipes-devtools/python/python-systemd.inc +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | SUMMARY = "Python interface for libsystemd" | ||
2 | HOMEPAGE = "https://github.com/systemd/python-systemd" | ||
3 | LICENSE = "LGPLv2.1+" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c" | ||
5 | |||
6 | PYPI_PACKAGE = "systemd-python" | ||
7 | DEPENDS += "systemd (<=234)" | ||
8 | RDEPENDS_${PN} += "systemd ${PYTHON_PN}-syslog ${PYTHON_PN}-logging" | ||
9 | REQUIRED_DISTRO_FEATURES = "systemd" | ||
10 | inherit pypi features_check | ||
11 | |||
12 | SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d" | ||
13 | SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7" | ||
14 | |||
15 | # allow for common patches for python- and python3-systemd | ||
16 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-systemd:" | ||
17 | |||
18 | SRC_URI += "file://endian.patch" | ||
19 | |||
20 | SRC_URI_append_libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch" | ||
diff --git a/meta-python/recipes-devtools/python/python3-systemd_234.bb b/meta-python/recipes-devtools/python/python3-systemd_234.bb index 78ec43156..6914cf920 100644 --- a/meta-python/recipes-devtools/python/python3-systemd_234.bb +++ b/meta-python/recipes-devtools/python/python3-systemd_234.bb | |||
@@ -1,3 +1,20 @@ | |||
1 | require python-systemd.inc | 1 | SUMMARY = "Python interface for libsystemd" |
2 | RDEPENDS_${PN} += "python3-syslog" | 2 | HOMEPAGE = "https://github.com/systemd/python-systemd" |
3 | inherit setuptools3 | 3 | LICENSE = "LGPLv2.1+" |
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c" | ||
5 | |||
6 | PYPI_PACKAGE = "systemd-python" | ||
7 | DEPENDS += "systemd (<=234)" | ||
8 | RDEPENDS_${PN} += "systemd ${PYTHON_PN}-syslog ${PYTHON_PN}-logging python3-syslog" | ||
9 | REQUIRED_DISTRO_FEATURES = "systemd" | ||
10 | inherit pypi features_check setuptools3 | ||
11 | |||
12 | SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d" | ||
13 | SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7" | ||
14 | |||
15 | # allow for common patches for python- and python3-systemd | ||
16 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-systemd:" | ||
17 | |||
18 | SRC_URI += "file://endian.patch" | ||
19 | |||
20 | SRC_URI_append_libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch" | ||