diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-08-03 17:05:15 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-06 10:27:03 -0700 |
commit | 7e13f22f522a5620f1f6029f6daf1a230e6932a5 (patch) | |
tree | 6d1dedb2d046eeb367cc771525500c15fbca54bc /meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb | |
parent | 6fbfe8e8fce5b6e8bf535304766631668d30f8be (diff) | |
download | meta-openembedded-7e13f22f522a5620f1f6029f6daf1a230e6932a5.tar.gz |
python3-yarl: Upgrade 1.4.2 -> 1.5.1
Upgrade to release 1.5.1:
- Fix including relocated internal yarl._quoting_c C-extension
into published PyPI dists.
- Convert host to lowercase on URL building. #386
- Allow using mod operator (%) for updating query string (an alias
for update_query() method).
- Allow use of sequences such as list and tuple in the values of a
mapping such as dict to represent that a key has many values:
url = URL("http://example.com")
assert url.with_query({"a": [1, 2]}) == URL("http://example.com/?a=1&a=2")
- Support URL.build() with scheme and path (creates a relative
URL).
- Cache slow IDNA encode/decode calls.
- Add @final / Final type hints.
- Support URL authority/raw_authority properties and authority
argument of URL.build() method.
- Hide the library implementation details, make the exposed public
list very clean.
- Fix tests with newer Python (3.7.6, 3.8.1 and 3.9.0+).
- Fix a bug where query component, passed in a form of mapping or
sequence, is unquoted in unexpected way.
- Hide Query and QueryVariable type aliases in __init__.pyi, now
they are prefixed with underscore.
- Keep ipv6 brackets after updating port/user/password.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb | 29 |
1 files changed, 0 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb b/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb deleted file mode 100644 index 15d92065d..000000000 --- a/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | SUMMARY = "The module provides handy URL class for url parsing and changing" | ||
2 | HOMEPAGE = "https://github.com/aio-libs/yarl/" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b" | ||
5 | |||
6 | SRC_URI[md5sum] = "08ba0d6e18f460b44d9e5459f3d217ba" | ||
7 | SRC_URI[sha256sum] = "58cd9c469eced558cd81aa3f484b2924e8897049e06889e8ff2510435b7ef74b" | ||
8 | |||
9 | SRC_URI += " \ | ||
10 | file://run-ptest \ | ||
11 | " | ||
12 | |||
13 | PYPI_PACKAGE = "yarl" | ||
14 | |||
15 | inherit pypi ptest setuptools3 | ||
16 | |||
17 | RDEPENDS_${PN} = "\ | ||
18 | ${PYTHON_PN}-multidict \ | ||
19 | ${PYTHON_PN}-idna \ | ||
20 | " | ||
21 | |||
22 | RDEPENDS_${PN}-ptest += " \ | ||
23 | ${PYTHON_PN}-pytest \ | ||
24 | " | ||
25 | |||
26 | do_install_ptest() { | ||
27 | install -d ${D}${PTEST_PATH}/tests | ||
28 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
29 | } | ||