summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-02-09 12:00:17 +0300
committerKhem Raj <raj.khem@gmail.com>2024-02-09 09:52:17 -0800
commit421c31515307f67e921059ff59d9b1ed5cebca6d (patch)
treeced5a628bf50dd79d32bede0942c288e9f6f8d06 /meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb
parent45ae16dbcdb52b417284474255e553449d09ab50 (diff)
downloadmeta-openembedded-421c31515307f67e921059ff59d9b1ed5cebca6d.tar.gz
python3-werkzeug: upgrade 2.3.6 -> 3.0.1
Upstream provides a pyproject.toml which declares a flit_core.buildapi build backend for PEP-517 packaging instead of setuptools. Also, RDEPENDS updated according to it. Removed CLEANBROKEN because it is not necessary. Changelog: Version 3.0.1 Fix slow multipart parsing for large parts potentially enabling DoS attacks. CWE-407 Version 3.0.0 Remove previously deprecated code. Deprecate the __version__ attribute. Use feature detection, or importlib.metadata.version("werkzeug"), instead. generate_password_hash uses scrypt by default. Add the "werkzeug.profiler" item to the WSGI environ dictionary passed to ProfilerMiddleware’s filename_format function. It contains the elapsed and time values for the profiled request. Explicitly marked the PathConverter as non path isolating. Version 2.3.8 Fix slow multipart parsing for large parts potentially enabling DoS attacks. CWE-407 Version 2.3.7 Use flit_core instead of setuptools as build backend. Fix parsing of multipart bodies. Adjust index of last newline in data start. Parsing ints from header values strips spacing first. Fix empty file streaming when testing. Clearer error message when URL rule does not start with slash. Accept q value can be a float without a decimal part. Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb b/meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb
new file mode 100644
index 000000000..6e500dde8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-werkzeug_3.0.1.bb
@@ -0,0 +1,19 @@
1SUMMARY = "The comprehensive WSGI web application library"
2DESCRIPTION = "\
3Werkzeug started as simple collection of various utilities for WSGI \
4applications and has become one of the most advanced WSGI utility modules. \
5It includes a powerful debugger, full featured request and response objects, \
6HTTP utilities to handle entity tags, cache control headers, HTTP dates, \
7cookie handling, file uploads, a powerful URL routing system and a bunch \
8of community contributed addon modules."
9HOMEPAGE = "https://werkzeug.palletsprojects.com"
10LICENSE = "BSD-3-Clause"
11LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
12
13SRC_URI[sha256sum] = "507e811ecea72b18a404947aded4b3390e1db8f826b494d76550ef45bb3b1dcc"
14
15inherit pypi python_flit_core
16
17RDEPENDS:${PN} += " \
18 ${PYTHON_PN}-markupsafe \
19"