summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-19 13:00:46 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-23 21:58:55 -0700
commitd29020784d00a3e2d935b956944988cbac37d7cc (patch)
treee5258fa80b2d4216ef945cb7c0790e7e356613a2 /meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb
parent48634c64b7069f8ac21f805ec3ede7850e8afcf2 (diff)
downloadmeta-openembedded-d29020784d00a3e2d935b956944988cbac37d7cc.tar.gz
python3-unidiff: Upgrade 0.6.0 -> 0.7.0
Upgrade to release 0.7.0: - Fixed issues handling multiple git renames. - Renamed files return target filename as PatchedFile.path. - Fixed error when first change is a binary file. - Added source code type hints. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb b/meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb
new file mode 100644
index 000000000..b3013180d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Unified diff parsing/metadata extraction library"
2HOMEPAGE = "http://github.com/matiasb/python-unidiff"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4c434b08ef42fea235bb019b5e5a97b3"
5
6SRC_URI[sha256sum] = "91bb13b4969514a400679d9ae5e29a6ffad85346087677f8b5e2e036af817447"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
23RDEPENDS:${PN} += " \
24 ${PYTHON_PN}-codecs \
25 ${PYTHON_PN}-io \
26"