summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-10-15 08:53:23 +0000
committerArmin Kuster <akuster808@gmail.com>2019-10-19 08:15:32 -0700
commit59475ff3927faad212816c1894c140ffae1eeabf (patch)
tree4907b494c22e10ad118214959365c016fc242979 /meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
parentcba875fdac3081137d8b33ee7fb5dc9e8d7818da (diff)
downloadmeta-openembedded-59475ff3927faad212816c1894c140ffae1eeabf.tar.gz
python3-twofish: Fix missing return statements in module stubs
* fixes build with -Werror=return-type twofish.c: In function 'init_twofish': twofish.c:45:1: error: control reaches end of non-void function [-Werror=return-type] 45 | PyMODINIT_FUNC init_twofish(void) { } | ^~~~~~~~~~~~~~ twofish.c: In function 'PyInit__twofish': twofish.c:46:1: error: control reaches end of non-void function [-Werror=return-type] 46 | PyMODINIT_FUNC PyInit__twofish(void) { } | ^~~~~~~~~~~~~~ cc1: some warnings being treated as errors Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
index e593f6f21..7b8eb2ef0 100644
--- a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
@@ -1,2 +1,4 @@
1require python-twofish.inc 1require python-twofish.inc
2inherit setuptools3 2inherit setuptools3
3
4SRC_URI += "file://0001-Fix-missing-return-statements-in-module-stubs.patch"