diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-06-12 17:42:01 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-06-13 21:34:21 -0700 |
commit | 2ff0eea40e4dd8b6509585c2a1225219c888ec1f (patch) | |
tree | a7d1c1b85a84a6e74e72c5bf2c1587192ddb7fcc /meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb | |
parent | 18a3ad7908f4066048cdccb0b7ae2300c3b7c59d (diff) | |
download | meta-openembedded-2ff0eea40e4dd8b6509585c2a1225219c888ec1f.tar.gz |
python3-twisted: Upgrade 19.10.0 -> 20.3.0
Upgrade to release 20.3.0. The year in file LICENSE has been
updated but the project remains available under MIT license.
The patch for test_runner.py is no longer needed because the same
fix has been already applied in the upstream. The new release
bring the following improvements:
- Bugfixes
- Improved documentation
- twisted.news is deprecated
- twisted.conch.ssh now supports the curve25519-sha256 key
exchange algorithm
- twisted.conch.ssh.keys can now write private keys in the new
"openssh-key-v1" format, introduced in OpenSSH 6.5 and made the
default in OpenSSH 7.8. ckeygen has a corresponding new
--private-key-subtype=v1 option.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb | 327 |
1 files changed, 0 insertions, 327 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb b/meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb deleted file mode 100644 index f2fcd30b7..000000000 --- a/meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb +++ /dev/null | |||
@@ -1,327 +0,0 @@ | |||
1 | DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \ | ||
2 | Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \ | ||
3 | (including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more." | ||
4 | HOMEPAGE = "http://www.twistedmatrix.com" | ||
5 | |||
6 | #twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL. | ||
7 | LICENSE = "MIT" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1743f12d8b8f5aec625c0569a058f0a6" | ||
9 | |||
10 | SRC_URI += "file://0001-fix-MemoryReactor-import-in-test_runner-to-be-from-t.patch" | ||
11 | |||
12 | SRC_URI[sha256sum] = "7394ba7f272ae722a74f3d969dcf599bc4ef093bc392038748a490f1724a515d" | ||
13 | SRC_URI[md5sum] = "f2d70f7a66ecdf54152310164cceadfe" | ||
14 | |||
15 | PYPI_PACKAGE = "Twisted" | ||
16 | PYPI_PACKAGE_EXT = "tar.bz2" | ||
17 | |||
18 | inherit pypi setuptools3 | ||
19 | |||
20 | do_install_append() { | ||
21 | # remove some useless files before packaging | ||
22 | find ${D} \( -name "*.bat" -o -name "*.c" -o -name "*.h" \) -exec rm -f {} \; | ||
23 | } | ||
24 | |||
25 | PACKAGES += "\ | ||
26 | ${PN}-zsh \ | ||
27 | ${PN}-test \ | ||
28 | ${PN}-protocols \ | ||
29 | ${PN}-conch \ | ||
30 | ${PN}-mail \ | ||
31 | ${PN}-names \ | ||
32 | ${PN}-news \ | ||
33 | ${PN}-runner \ | ||
34 | ${PN}-web \ | ||
35 | ${PN}-words \ | ||
36 | ${PN}-flow \ | ||
37 | ${PN}-pair \ | ||
38 | ${PN}-core \ | ||
39 | " | ||
40 | |||
41 | PACKAGES =+ "\ | ||
42 | ${PN}-bin \ | ||
43 | " | ||
44 | |||
45 | DEPENDS += " \ | ||
46 | ${PYTHON_PN}-incremental-native \ | ||
47 | " | ||
48 | |||
49 | RDEPENDS_${PN} = "\ | ||
50 | ${PN}-bin \ | ||
51 | ${PN}-core \ | ||
52 | ${PN}-conch \ | ||
53 | ${PN}-mail \ | ||
54 | ${PN}-names \ | ||
55 | ${PN}-pair \ | ||
56 | ${PN}-protocols \ | ||
57 | ${PN}-runner \ | ||
58 | ${PN}-web \ | ||
59 | ${PN}-words \ | ||
60 | ${PN}-zsh \ | ||
61 | " | ||
62 | |||
63 | RDEPENDS_${PN}-core = "${PYTHON_PN}-appdirs \ | ||
64 | ${PYTHON_PN}-automat \ | ||
65 | ${PYTHON_PN}-constantly \ | ||
66 | ${PYTHON_PN}-core \ | ||
67 | ${PYTHON_PN}-debugger \ | ||
68 | ${PYTHON_PN}-hyperlink \ | ||
69 | ${PYTHON_PN}-incremental \ | ||
70 | ${PYTHON_PN}-pyhamcrest \ | ||
71 | ${PYTHON_PN}-pyserial \ | ||
72 | ${PYTHON_PN}-unixadmin \ | ||
73 | ${PYTHON_PN}-zopeinterface \ | ||
74 | " | ||
75 | RDEPENDS_${PN}-test = "${PN}" | ||
76 | RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols ${PYTHON_PN}-bcrypt ${PYTHON_PN}-cryptography ${PYTHON_PN}-pyasn1 ${PYTHON_PN}-pickle" | ||
77 | RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols" | ||
78 | RDEPENDS_${PN}-names = "${PN}-core" | ||
79 | RDEPENDS_${PN}-news = "${PN}-core ${PN}-protocols" | ||
80 | RDEPENDS_${PN}-runner = "${PN}-core ${PN}-protocols" | ||
81 | RDEPENDS_${PN}-web += "${PN}-core ${PN}-protocols" | ||
82 | RDEPENDS_${PN}-words += "${PN}-core" | ||
83 | RDEPENDS_${PN}-flow += "${PN}-core" | ||
84 | RDEPENDS_${PN}-pair += "${PN}-core" | ||
85 | RDEPENDS_${PN}-dbg = "${PN}" | ||
86 | |||
87 | ALLOW_EMPTY_${PN} = "1" | ||
88 | FILES_${PN} = "" | ||
89 | |||
90 | FILES_${PN}-test = " \ | ||
91 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \ | ||
92 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \ | ||
93 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy/test/ \ | ||
94 | " | ||
95 | |||
96 | FILES_${PN}-protocols = " \ | ||
97 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \ | ||
98 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \ | ||
99 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \ | ||
100 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy \ | ||
101 | " | ||
102 | |||
103 | FILES_${PN}-zsh = " \ | ||
104 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \ | ||
105 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \ | ||
106 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/twisted-completion.zsh \ | ||
107 | " | ||
108 | |||
109 | FILES_${PN}-conch = " \ | ||
110 | ${bindir}/ckeygen \ | ||
111 | ${bindir}/tkconch \ | ||
112 | ${bindir}/conch \ | ||
113 | ${bindir}/conchftp \ | ||
114 | ${bindir}/cftp \ | ||
115 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \ | ||
116 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \ | ||
117 | " | ||
118 | |||
119 | FILES_${PN}-core = " \ | ||
120 | ${bindir}/manhole \ | ||
121 | ${bindir}/mktap \ | ||
122 | ${bindir}/twistd \ | ||
123 | ${bindir}/tap2deb \ | ||
124 | ${bindir}/tap2rpm \ | ||
125 | ${bindir}/tapconvert \ | ||
126 | ${bindir}/tkmktap \ | ||
127 | ${bindir}/trial \ | ||
128 | ${bindir}/easy_install* \ | ||
129 | ${bindir}/pyhtmlizer \ | ||
130 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.so \ | ||
131 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \ | ||
132 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \ | ||
133 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \ | ||
134 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \ | ||
135 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \ | ||
136 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \ | ||
137 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \ | ||
138 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \ | ||
139 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \ | ||
140 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \ | ||
141 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \ | ||
142 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \ | ||
143 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/application \ | ||
144 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \ | ||
145 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \ | ||
146 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \ | ||
147 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \ | ||
148 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \ | ||
149 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \ | ||
150 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\ | ||
151 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python\ | ||
152 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \ | ||
153 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \ | ||
154 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \ | ||
155 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \ | ||
156 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \ | ||
157 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \ | ||
158 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \ | ||
159 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \ | ||
160 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \ | ||
161 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \ | ||
162 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \ | ||
163 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \ | ||
164 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \ | ||
165 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \ | ||
166 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \ | ||
167 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \ | ||
168 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \ | ||
169 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \ | ||
170 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \ | ||
171 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \ | ||
172 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \ | ||
173 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \ | ||
174 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \ | ||
175 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \ | ||
176 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \ | ||
177 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \ | ||
178 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \ | ||
179 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \ | ||
180 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \ | ||
181 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \ | ||
182 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \ | ||
183 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \ | ||
184 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \ | ||
185 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \ | ||
186 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \ | ||
187 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \ | ||
188 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \ | ||
189 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \ | ||
190 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \ | ||
191 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \ | ||
192 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \ | ||
193 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \ | ||
194 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \ | ||
195 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \ | ||
196 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \ | ||
197 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \ | ||
198 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \ | ||
199 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \ | ||
200 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \ | ||
201 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \ | ||
202 | ${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \ | ||
203 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/logger/ \ | ||
204 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/_threads/ \ | ||
205 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/positioning/ \ | ||
206 | " | ||
207 | |||
208 | FILES_${PN}-mail = " \ | ||
209 | ${bindir}/mailmail \ | ||
210 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \ | ||
211 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \ | ||
212 | " | ||
213 | |||
214 | FILES_${PN}-names = " \ | ||
215 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \ | ||
216 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/names \ | ||
217 | " | ||
218 | |||
219 | FILES_${PN}-news = " \ | ||
220 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \ | ||
221 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/news \ | ||
222 | " | ||
223 | |||
224 | FILES_${PN}-runner = " \ | ||
225 | ${libdir}/site-packages/twisted/runner/portmap.so \ | ||
226 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\ | ||
227 | " | ||
228 | |||
229 | FILES_${PN}-web = " \ | ||
230 | ${bindir}/websetroot \ | ||
231 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \ | ||
232 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/web\ | ||
233 | " | ||
234 | |||
235 | FILES_${PN}-words = " \ | ||
236 | ${bindir}/im \ | ||
237 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \ | ||
238 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/words\ | ||
239 | " | ||
240 | |||
241 | FILES_${PN}-flow = " \ | ||
242 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \ | ||
243 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \" | ||
244 | |||
245 | FILES_${PN}-pair = " \ | ||
246 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \ | ||
247 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \ | ||
248 | " | ||
249 | |||
250 | FILES_${PN}-dbg += " \ | ||
251 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \ | ||
252 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \ | ||
253 | " | ||
254 | |||
255 | FILES_${PN}-doc += " \ | ||
256 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \ | ||
257 | " | ||
258 | |||
259 | RDEPENDS_${PN}-src = "${PN}" | ||
260 | FILES_${PN}-src = " \ | ||
261 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \ | ||
262 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \ | ||
263 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \ | ||
264 | " | ||
265 | |||
266 | FILES_${PN}-core_append = " \ | ||
267 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \ | ||
268 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \ | ||
269 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/__init__*.pyc \ | ||
270 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/notestplugin*.pyc \ | ||
271 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/testplugin*.pyc \ | ||
272 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_ftp*.pyc \ | ||
273 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_inet*.pyc \ | ||
274 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_manhole*.pyc \ | ||
275 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_portforward*.pyc \ | ||
276 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_socks*.pyc \ | ||
277 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_telnet*.pyc \ | ||
278 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_trial*.pyc \ | ||
279 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_core*.pyc \ | ||
280 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_qtstub*.pyc \ | ||
281 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_reactors*.pyc \ | ||
282 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/cred*.pyc \ | ||
283 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/dropin*.cache \ | ||
284 | " | ||
285 | |||
286 | FILES_${PN}-names_append = " \ | ||
287 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_names*.pyc \ | ||
288 | " | ||
289 | |||
290 | FILES_${PN}-news_append = " \ | ||
291 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_news*.pyc \ | ||
292 | " | ||
293 | |||
294 | FILES_${PN}-protocols_append = " \ | ||
295 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/__pycache__/*pyc \ | ||
296 | " | ||
297 | |||
298 | FILES_${PN}-conch_append = " \ | ||
299 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_conch*.pyc \ | ||
300 | " | ||
301 | |||
302 | FILES_${PN}-lore_append = " \ | ||
303 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_lore*.pyc \ | ||
304 | " | ||
305 | FILES_${PN}-mail_append = " \ | ||
306 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_mail*.pyc \ | ||
307 | " | ||
308 | |||
309 | FILES_${PN}-web_append = " \ | ||
310 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_web*.pyc \ | ||
311 | " | ||
312 | |||
313 | FILES_${PN}-words_append = " \ | ||
314 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_words*.pyc \ | ||
315 | " | ||
316 | |||
317 | FILES_${PN}-flow_append = " \ | ||
318 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_flow*.pyc \ | ||
319 | " | ||
320 | |||
321 | FILES_${PN}-pair_append = " \ | ||
322 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_pair*.pyc \ | ||
323 | " | ||
324 | |||
325 | FILES_${PN}-runner_append = " \ | ||
326 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_runner*.pyc \ | ||
327 | " | ||