diff options
author | Yue Tao <Yue.Tao@windriver.com> | 2023-03-20 10:59:58 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-03-22 09:10:39 -0700 |
commit | a4b6e3ee894047cd13c5d2b7bfc67f0093899537 (patch) | |
tree | 521fca69529b760c34904a0b237cf9187f749351 /meta-python/recipes-devtools/python/python3-trustme_0.9.0.bb | |
parent | edea484f2dee3e4d7101b14f4a22d28be0291aa0 (diff) | |
download | meta-openembedded-a4b6e3ee894047cd13c5d2b7bfc67f0093899537.tar.gz |
Introduce python3-trustme to fix ptest error of python3-requests-toolbelt
The ptest fails after python3-requests-toolbelt is upgraded
to 0.10.1.
=======================================================
Hint: make sure your test modules/packages have valid Python names.
Traceback:
../../python3.11/importlib/{}init{}.py:126: in import_module
return _bootstrap._gcd_import(name[level:], package, level)
tests/test_x509_adapter.py:20: in <module>
import trustme
E ModuleNotFoundError: No module named 'trustme'
=======================================================
The commit b93b4067ea "Fix x509 tests by using trustme" of
python3-requests-toolbelt introduces the trustme in test_x509_adapter.py.
Introducing python3-trustme to fix ptest error of python3-requests-toolbelt,
also introducing python3-service-identity, which is requested by python3-trustme's
ptest.
The ptest passes of all the three packages.
Signed-off-by: Yue Tao <Yue.Tao@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-trustme_0.9.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-trustme_0.9.0.bb | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-trustme_0.9.0.bb b/meta-python/recipes-devtools/python/python3-trustme_0.9.0.bb new file mode 100644 index 000000000..641512c46 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-trustme_0.9.0.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | DESCRIPTION = "A utility provides a fake certificate authority (CA)" | ||
2 | HOMEPAGE = "https://pypi.org/project/trustme" | ||
3 | AUTHOR = "Nathaniel J. Smith" | ||
4 | |||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d5a7af1a4b73e57431e25d15a2da745a" | ||
7 | |||
8 | SRC_URI[md5sum] = "0e4d698e5aecaf8306cf440bf3dcbbe0" | ||
9 | SRC_URI[sha256sum] = "5e07b23d70ceed64f3bb36ae4b9abc52354c16c98d45ab037bee2b5fbffe586c" | ||
10 | |||
11 | inherit pypi setuptools3 ptest | ||
12 | |||
13 | SRC_URI += " \ | ||
14 | file://run-ptest \ | ||
15 | " | ||
16 | |||
17 | RDEPENDS:${PN}-ptest += " \ | ||
18 | ${PYTHON_PN}-pytest \ | ||
19 | ${PYTHON_PN}-service-identity \ | ||
20 | ${PYTHON_PN}-pyasn1-modules \ | ||
21 | " | ||
22 | |||
23 | do_install_ptest() { | ||
24 | install -d ${D}${PTEST_PATH}/tests | ||
25 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
26 | cp -rf ${S}/setup.py ${D}${PTEST_PATH} | ||
27 | } | ||