summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-tqdm_4.66.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-08-16 09:38:38 +0800
committerKhem Raj <raj.khem@gmail.com>2023-08-16 11:39:45 -0700
commit59e614fe67683268e08f91b1319f608ae08cbf48 (patch)
tree8c752fae9f50c39d269fb57b309eb9ad2e9e5c1c /meta-python/recipes-devtools/python/python3-tqdm_4.66.1.bb
parent653b49ad9c12409b0ba26857a97f5b7d17ab18aa (diff)
downloadmeta-openembedded-59e614fe67683268e08f91b1319f608ae08cbf48.tar.gz
python3-tqdm: upgrade 4.65.0 -> 4.66.1
License-Update: MPLv2.0 changed to MPL-2.0 setup.py and MANIFEST.in removed from files Changelog: =========== - fix utils.envwrap types (#1493 <- #1491, #1320 <- #966, #1319) - drop mentions of unsupported Python versions - environment variables to override defaults (TQDM_*) (#1491 <- #1061, #950 <- #614, #1318, #619, #612, #370) - fix & update CLI completion - fix & update API docs - minor code tidy: replace os.path => pathlib.Path - fix docs image hosting - release with CI bot account again (https://github.com/cli/cli/issues/6680) - exclude examples from distributed wheel (#1492) - migrate setup.{cfg,py} => pyproject.toml (#1490) fix asv benchmarks update docs - fix snap build (#1490) - fix & update tests (#1490) fix flaky notebook tests bump pre-commit bump workflow actions Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tqdm_4.66.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-tqdm_4.66.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tqdm_4.66.1.bb b/meta-python/recipes-devtools/python/python3-tqdm_4.66.1.bb
new file mode 100644
index 000000000..2a92e6189
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tqdm_4.66.1.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Fast, Extensible Progress Meter"
2HOMEPAGE = "http://tqdm.github.io/"
3SECTION = "devel/python"
4
5LICENSE = "MIT & MPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=bb3c087935ebba37cad180364cb0850c"
7
8SRC_URI[sha256sum] = "d88e651f9db8d8551a62556d3cff9e3034274ca5d66e93197cf2490e2dcb69c7"
9
10inherit pypi python_setuptools_build_meta
11
12DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
13
14RDEPENDS:${PN} += " \
15 python3-logging \
16 python3-numbers \
17"
18
19BBCLASSEXTEND = "native nativesdk"