diff options
author | alperak <alperyasinak1@gmail.com> | 2024-03-07 22:45:27 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-03-08 10:07:27 -0800 |
commit | 18e019ee2295ab42849e510d5efeee94bf1d9056 (patch) | |
tree | 9a5e9077c7aaf6931bffb5c8ce1f7da722d41e38 /meta-python/recipes-devtools/python/python3-tomli-w_1.0.0.bb | |
parent | cbb570cdd963de547e4fa94ca1851d8d889a7cf3 (diff) | |
download | meta-openembedded-18e019ee2295ab42849e510d5efeee94bf1d9056.tar.gz |
python3-tomli-w: added recipe which is also include ptest
Tomli-W is the write-only counterpart of Tomli, providing dump and dumps functions.
* When we fetch the package via PyPI there are missing files such as tests directory. So, we set PYPI_SRC_URI and fetch it from the github url.
* Ptest and library example tested on qemux86-64 and qemuarm64
* Add ptest into PTESTS_FAST_META_PYTHON
Ptest result:
==============
qemux86-64:
Testsuite summary
TOTAL: 265
PASS: 263
SKIP: 0
XFAIL: 2
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 15
END: /usr/lib/python3-tomli-w/ptest
2024-03-07T17:33
STOP: ptest-runner
TOTAL: 1 FAIL: 0
qemuarm64:
Testsuite summary
TOTAL: 265
PASS: 263
SKIP: 0
XFAIL: 2
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 15
END: /usr/lib/python3-tomli-w/ptest
2024-03-07T17:25
STOP: ptest-runner
TOTAL: 1 FAIL: 0
XFAIL: tests/test_valid.py:test_valid[qa-array-inline-nested-1000] XFAIL reason: This much recursion is not supported
Signed-off-by: alperak <alperyasinak1@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tomli-w_1.0.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-tomli-w_1.0.0.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tomli-w_1.0.0.bb b/meta-python/recipes-devtools/python/python3-tomli-w_1.0.0.bb new file mode 100644 index 000000000..8a8a48467 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-tomli-w_1.0.0.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | DESCRIPTION = "Tomli-W is a Python library for writing TOML. It is a write-only counterpart to Tomli, which is a read-only TOML parser." | ||
2 | HOMEPAGE = "https://github.com/hukkin/tomli-w" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5" | ||
5 | |||
6 | SRCREV = "19099125f32e7c491603e393263754262b356956" | ||
7 | PYPI_SRC_URI = "git://github.com/hukkin/tomli-w.git;protocol=https;branch=master" | ||
8 | |||
9 | inherit pypi python_flit_core ptest | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | SRC_URI += " \ | ||
14 | file://run-ptest \ | ||
15 | " | ||
16 | |||
17 | RDEPENDS:${PN}-ptest += " \ | ||
18 | python3-pytest \ | ||
19 | python3-tomli \ | ||
20 | python3-unittest-automake-output \ | ||
21 | " | ||
22 | |||
23 | do_install_ptest() { | ||
24 | install -d ${D}${PTEST_PATH}/tests | ||
25 | install -d ${D}${PTEST_PATH}/benchmark | ||
26 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
27 | cp -rf ${S}/benchmark/* ${D}${PTEST_PATH}/benchmark/ | ||
28 | } | ||
29 | |||
30 | RDEPENDS:${PN} += " \ | ||
31 | python3-datetime \ | ||
32 | python3-numbers \ | ||
33 | python3-stringold \ | ||
34 | " | ||